Contenu | Rechercher | Menus
Selon les tags présents sur cette page, les informations qu'elle contient n'ont pas été vérifiées depuis Ubuntu 12.04 LTS.
Apportez votre aide…

Open-Sankoré : Utiliser un tableau numérique

Open-Sankoré (anciennement Sankoré) est un logiciel de gestion de tableau numérique interactif dérivant de l'ouverture open source du logiciel uniboard. Ce logiciel libre fonctionne avec différentes marques de tableau numérique comme SmartBoard, Epson, InterWriteLearning, Prométhéan, Hitachi…

Autre plus du logiciel, Open-Sankoré est disponible aussi pour Windows© et MacOS©. De cette façon, un cours réalisé avec le logiciel Open-Sankoré est portable sur n'importe quel ordinateur.

Pré-requis

Installation

Precise 12.04 LTS et Quantal Quetzal 12.10

Open-Sankoré 2.1 n'est toujours pas disponible dans les dépôts officiels.

Il existe un paquet .deb du logiciel prêt à l'installation en version 32 bits et 64 bits pour Precise, Lucid et Debian à télécharger sur la page téléchargement du site : Open-Sankoré. C'est la version 2.1.0 (les anciennes versions sont aussi disponibles depuis ce lien).

Télécharger le fichier compressé qui vous intéresse. Puis extraire ce fichier. Dans le dossier ainsi créé il y a un paquet .deb qu'il suffit de lancer dans la logithèque pour l'installer (voir comment_installer_un_paquet).

Le lien pour démarrer le logiciel se trouve dans les applications, dans la partie "éducation".

Attention : Si vous utilisez la version Ubuntu 12.10

Le paquet conçu pour la version 12.04 ne fonctionne pas correctement. Dans l'attente d'une version compilée proposée pour cette version par une âme charitable, vous pouvez utiliser Gdebi http://doc.ubuntu-fr.org/gdebi qui vous aide à contourner le problème. Grâce à cette application, l'installation se réalise proprement et sans trop de manipulations. Le logiciel fonctionne bien et de façon stable.

Installation rapide pour la 12.04 LTS

Pour la version 32 bits :

Télécharger le paquet

wget http://ftp.open-sankore.org/current/Open-Sankore_Ubuntu_12.04_2.00.00_i386.zip

Extraire

unzip Open-Sankore_Ubuntu_12.04_2.00.00_i386.zip

Se rendre dans de répertoire fraichement décompressé

cd Open-Sankore_Ubuntu_12.04_2.00.00_i386\ Folder

Installer

sudo dpkg -i Open-Sankore_2.00.00_i386.deb
Pour la version 64 bits :

Télécharger le paquet

wget http://ftp.open-sankore.org/current/Open-Sankore_Ubuntu_12.04_2.00.00_amd64.zip

Extraire

unzip Open-Sankore_Ubuntu_12.04_2.00.00_amd64.zip

Se rendre dans de répertoire fraichement décompressé

cd Open-Sankore_Ubuntu_12.04_2.00.00_amd64\ Folder

Installer

sudo dpkg -i Open-Sankore_2.00.00_amd64.deb

Retour d'expérience : la procédure ci-dessus ne fonctionne pas. La version en août 2013 d'Open-Sankoré est la version 2.1. Il faut la télécharger depuis le site http://open-sankore.org/fr/telechargement, décompresser l'archive. Ensuite, pour la version 64bits, il faut installer les paquets suivants : apt://ia32-libs,lib32z1 avant d'installer le paquet Sankoré.

Lucid 10.04 LTS, Maverick 10.10, Natty 11.04 et Oneiric 11.10

Sankore n'est pas disponible dans les dépôts officiels mais il est possible d'installer la version dédiée à la version Lucid 10.04 LTS en utilisant les paquets deb fournis sur les pages de téléchargement.

→ la dernière version stable (2.0) http://ftp.open-sankore.org/current/

→ la dernière version beta (2.1RC2) http://ftp.open-sankore.org/beta/2.10.RC2/

C'est cette version d'Ubuntu qui est utilisée sur 4 700 ordinateurs portables des classes numériques offertes dans les classes des pays africains et en Haiti.

Il existe un paquet .deb prêt à l'installation du logiciel en version 32 bits et 64 bits pour Lucid, Maverick et Natty proposé par : Serge COUDÉ. La version installée est 3en1, 1.25.00.

Cette version a un bug sur le clavier virtuel en qwerty, le bug est remonté aux développeurs.

Il est possible aussi d'installer un paquet deb 32 bits ou 64 bits réalisé par les développeurs de l'équipe du terrier d'Abulédu. Cette version est plus ancienne.

Cette version est partiellement compatible avec la version 3en1 1.25.00 pour windows®, des soucis de transfert d'écriture existent…

Téléchargez le paquet d'un des liens cités, puis installez-le.

Compilation à partir des sources

Téléchargement

Pour télécharger les fichiers (il faut tous les mettre dans le même dossier car la compilation de Sankore va chercher ses fichiers dans Sankore-ThirdParty) :

mkdir Sankore
cd Sankore
git clone https://github.com/Sankore/Sankore-3.1
git clone git://github.com/Sankore/Sankore-ThirdParty.git

puis installez Qt via

sudo apt-get install libqt4-dev

ou si vous voulez installer la version Qt prévue par Sankoré téléchargez les paquets suivants (je pense que l'installation de cette version est facultative)

git clone git://gitorious.org/+mnemis/qt/mnemogit.git Qt-sankore3.1
git checkout --track -b sankore3.1 origin/sankore3.1

Lancez ensuite

sudo apt-get install zlib1g-dev libjpeg62-dev libpng12-dev libgstreamer-plugins-base0.10-dev libgstreamer0.10-dev libpulse-dev libaudio-dev libasound2-dev libfreetype6-dev libfontconfig1-dev libts-dev libcups2-dev libdbus-1-dev libglib2.0-dev libgtk2.0-dev libx11-dev libxext-dev libxcursor-dev libxfixes-dev libxrandr-dev libxrender-dev libxv-dev libxinerama-dev libxi-dev libsm-dev libssl-dev libphonon-dev libt1-dev libpaper-dev

pour installer les dépendances nécessaires.

Pour installer Qt version Sankoré (facultatif je pense)

Si vous souhaitez installer la version Qt de Sankoré lancez : cd Qt-sankore3.1 ./configure -debug-and-release -arch `arch` -make "libs tools" -opensource -confirm-license make sudo make install cd ..

Pour le mettre dans un dossier personalisé (/opt par exemple, car par défaut Qt est installé dans /usr/share/Trolltech ce qui est assez étrange comme emplacement), il faut rajouter lors de la commande ./configure l'option -prefix <nom_dossier>, avant de l'ajouter dans votre path en ajoutant dans votre fichier ~/.bashrc :

export PATH=${PATH}:<nom_dossier>

puis lancez pour actualiser

source ~/.bashrc

Pour compiler les Third parties

Avant de compiler Sankore il faut d'abord compiler les Third parties ainsi :

Installer libpaper-dev et libt1-dev si ce n'est déjà fait

sudo apt-get install libpaper-dev libt1-dev

Puis compiler en lisant les README (il y a les commandes) d'abord freetype, puis xpdf (je pense que les autres sont compilés directement depuis Sankore) , ou précédez directement comme ceci (je n'ai fait que recopier les README) :

cd Sankore-ThirdParty/freetype
qmake freetype.pro -spec linux-g++
make
cd ../xpdf/xpdf-3.03
./configure --with-freetype2-library="../../freetype/lib/linux" --with-freetype2-includes="../../freetype/freetype-2.4.6/include"
cd ..
qmake xpdf.pro -spec linux-g++
make
cd ..

Compilation de Sankore

Enfin on arrive à l'étape finale

qmake Sankore_3.1.pro -spec linux-g++-32

ou

qmake Sankore_3.1.pro -spec linux-g++-64

suivant si vous êtes en 32 ou 64 bits, puis

make
make install

L'exécutable est alors par défault dans build/linux/release/product/Open-sankore, vous pouvez alors le renommer si vous préférez l'avoir en minuscule :

mv build/linux/release/product/Open-Sankore build/linux/release/product/open-sankore

puis le copier dans /usr/bin/ ainsi :

sudo cp build/linux/release/product/open-sankore /usr/bin/open-sankore

pour l'ajouter à tous les utilisateurs où alors le laisser dans ce dossier et ajouter ce dossier dans le path en l'ajoutant dans votre ~/.bashrc en ajoutant à la fin :

export PATH=${PATH}:<nom_dossier>

puis lancez pour actualiser

source ~/.bashrc

Il ne reste plus qu'à créer un raccourcis dans vos menus si vous le souhaitez vers la commande open-sankore !

Utilisation

Lancez l'application depuis le menu Applications → Education → Sankore.

Le logiciel est constitué de palettes dédiées à des outils pédagogiques qui sont activés à l'aide d'un stylo numérique.

  • Sur la gauche de l'écran, une palette outils Dessin/gomme/crayon/zoom/galerie qui permet de rapidement modifier le comportement du curseur sous le stylo numérique, et donc d'écrire comme sur un tableau noir, dessiner, effacer, déplacer…
  • Sur le bord haut de l'écran, les outils de navigation dans la paperboard, l'équivalent des pages d'un livre, les outils généralistes de fond, les encres et tailles des mines…

Il est possible d'importer dans la bibliothèque du logiciel vos propres images, clip-arts, textes, schémas, dessins afin de compléter et de rendre attractif votre démonstration au tableau numérique interactif.

Problème rencontré

Si le passage en mode "Bureau" remplace le fond par une zone noire opaque, (rencontré notamment sous 10.04, Mint13, etc.), activer le "composing". Par exemple (sous Mint13 en tout cas) avec Mate: Menu > Centre de Contrôle > Paramètres du bureau > Fenêtres > Cocher "Use compositing/Utiliser le compositing" Voir: http://www.linuxmint-fr.org/forum/science-et-education/156112-resolu-linux-mint-13-et-open-sankore.html

Outils utiles pour l'utilisation d'un vidéoprojecteur

Pour régler les problèmes de résolution avec l'ordinateur, aller sur cette page : http://doc.ubuntu-fr.org/multi-ecran

Désinstallation

Pour supprimer cette application, il suffit de supprimer son paquet. Selon la méthode choisie, la configuration globale de l'application est conservée ou supprimée. Les journaux du système, et les fichiers de préférence des utilisateurs dans leurs dossiers personnels sont toujours conservés.

Voir aussi



Le contenu de ce wiki est sous licence : CC BY-SA v3.0