Contenu | Rechercher | Menus

 Logo de Blender

Blender : suite de création 3D

screenshot blender Blender est un logiciel de modélisation 3D, animation et rendu. Il est à la 3D ce que GIMP est à la 2D, ni plus ni moins, en ce sens que Blender va taquiner les grands du marché comme 3DsMax de la même manière que GIMP va concurrencer la référence Photoshop. Eh oui, c’est fort de ses outils de modélisation, d’animation, de rendu et même de temps réel que Blender se pose en « outsider » très sérieux…

Les sources de Blender sont disponibles pour qui voudra y apporter une amélioration, et l’ensemble est coordonné par la Blender Foundation pour éviter un développement chaotique.

La fondation Blender a coordonné la réalisation de plusieurs courts métrages afin de démontrer les capacités du logiciel :

  • Elephants Dream en 2006, premier court métrage d'animation open source de l'histoire,
  • Big Buck Bunny en 2008,
  • Sintel en 2010,
  • Tears of Steel en 2012, court métrage avec de vrais acteurs où Blender est utilisé pour tous les effets spéciaux.

Pré-requis

Installation

Blender évolue rapidement avec une nouvelle version stable tous les 2 mois.

Depuis les versions 2.5 (fin 2009), l'interface a été totalement refaite. Ces dernières versions sont plus claires, mieux organisées et plus faciles à naviguer que les précédentes (2.49b et antérieures).

Version stable à partir des dépôts (conseillé)

Blender étant disponible dans Ubuntu, il vous suffit d'installer le paquet blender après avoir activé les dépôts Universe. La version de Blender qui sera installée sera fonction de la version d'Ubuntu que vous utilisez.

Version Ubuntu Version installée
Ubuntu 14.04 2.69
Ubuntu 12.04 LTS 2.62
Ubuntu 10.04 LTS 2.49

Version stable la plus récente à partir du site Blender.org

Vous pouvez télécharger puis extraire le binaire Blender version 2.7x sur la page de téléchargement. Il s'agit donc de la version stable mise à jour tous les 2 mois. Aucune installation n'est requise : dans le dossier extrait, il suffit de lancer le fichier blender pour exécuter l'application.

Version de développement via un dépot ppa

La version mise à disposition est compilée toutes les semaines environ. Les dernières nouveautés apportées au logiciel sont donc disponibles, en contrepartie d'une moindre stabilité.

Compiler manuellement la dernière version de développement

Il peut être utile de compiler Blender pour bénéficier des toutes dernières améliorations, ou encore pour produire un binaire optimisé pour votre processeur. Rendez-vous sur cette page pour la procédure complète.

Configurations matérielles conseillées

Trois éléments à prendre en compte dans cet ordre : processeur, carte graphique, mémoire (RAM).

  1. Le processeur est sollicité lors des phases de rendu, ainsi que la RAM. Il influe directement sur le temps de rendu. Blender est compatible 64bits et gère jusqu'à 64 calculateurs en parallèle (donc pas de problème pour les possesseurs de processeurs à deux ou quatre cœurs, voire de bi-pro).
  2. La carte graphique est importante elle aussi pour les conditions de travail. Une bonne carte permet d'afficher un grand nombre de polygones à l'écran de manière fluide, ce n'est donc pas à négliger. Évidemment une bonne carte graphique est également nécessaire pour l'utilisation du moteur de jeu de Blender. Une bonne carte compatible CUDA et GPU Compute 2.0 permet également un rendu ultra-rapide avec le nouveau moteur de rendu Cycles.
  3. La RAM est rarement un facteur limitant, mais dans certaines conditions le besoin de mémoire peut se faire plus grand, comme par exemple avec une simulation de fluides où beaucoup de RAM est nécessaire. L'utilisation des systèmes de particules à grande échelle consomme aussi beaucoup de RAM.

Suggestion de configuration minimale pour débuter sur des scènes peu complexes :

  • Processeur équivalent Pentium III 750MHz ou supérieur.
  • Carte graphique compatible OpenGL de type GeForce2 32Mo.
  • 128Mo de RAM

Suggestion de configuration intermédiaire pour utiliser Blender de manière correcte sur des scènes plus importantes :

  • Processeur équivalent Pentium 4 1.8GHz ou supérieur.
  • Carte graphique compatible OpenGL de type GeForce5 128Mo.
  • 512Mo de RAM

Suggestion de configuration solide pour utiliser Blender de manière correcte sur des scènes assez complexes de manière fluide :

  • Processeur équivalent Corei7 ou Xeon.
  • Carte graphique compatible CUDA et GPU Compute 2.0 minimum.
  • 18Go de RAM

Toutes ces configurations sont indiquées à titre purement indicatif afin de vous faire une idée de l'utilisabilité de Blender selon votre machine et ce que vous voulez faire avec. Notez qu'une machine avec des spécifications inférieures à la configuration minimale peut éventuellement fonctionner, mais peut-être pas dans des conditions idéales de travail.

Questions courantes

Moteurs de rendu

Blender dispose d'un moteur de rendu historique appelé "Blender Internal". Il ne fait plus l'objet de développement. Depuis la version 2.61 de Blender, un nouveau moteur a fait son apparition : Cycles. Ce moteur repose sur le principe du "lancer de rayon" (ou "ray tracing") et est en cours de développement. Il est déjà parfaitement fonctionnel. Pour utiliser Cycles sur Ubuntu 12.04, cf. cette discussion. Les 2 moteurs sont disponibles dans Blender avec peut-être, à terme, la disparition du moteur "Blender Internal".

Par ailleurs il existe dans les dépôts de logiciels plusieurs moteurs externes de rendu compatibles avec Blender :

yafaray aqsis radiance gman

Comment mettre Blender en français ?

Blender 2.49b et avant : positionner le curseur sur la bordure inférieure du menu principal (en haut). Celui-ci change alors de forme (double flèche). Cliquer puis tirer vers le bas : un menu devient visible. Cliquer sur Language & Fonts puis choisissez French et cliquez sur les icônes Bulles d'aide, Boites à outils, Boutons.

Tapez Ctrl + U pour sauvegarder cette configuration.

Blender 2.5 et après : menu "File", "User Préférences", Onglet "System", en bas à droite cochez "International fonts" et choisir Français. ( cochez les cases et sauvegarder )

Mettre Blender en français n'est pas forcément une bonne initiative. En effet, la 3D a un jargon technique particulier difficilement traduisible. Certains mots vous seront donc incompréhensibles. De même, tous les tutoriels (ou presque) que vous trouverez sur internet seront sous une version anglaise de Blender. Il sera donc moins aisé de les suivre.

Comment avoir Blender fenêtré ?

En ligne de commande, lancer blender -w ouvre Blender fenêtré (et non en plein écran). Le lancer avec blender -W (majuscule et non plus minuscule, ouvre en plein écran).

Problème d'affichage sur carte Intel GMA4500

En cas de polices floues, d'interface dont les fenêtres laissent des traces ou d'icônes invisibles, suivez cette procédure :

  • Désactivez les effets visuels (Compiz)
  • Éditez le fichier /etc/X11/xorg.conf et rajouter dans la Section Device de votre carte vidéo
    Option "DRI" "false"
  • Téléchargez le .DEB sur le site de Blender la version 2.49 ou supérieur

Un fois votre machine redémarrée, Blender devrait s'afficher correctement.

Comment rétablir le ALT + clic droit et Ctrl + Alt + S dans Blender ?

Dans Blender, la combinaison ALT + clic droit permet de sélectionner en mode EDIT une série continue de vertices / edges / faces. Or cette combinaison de touches permet dans Ubuntu de faire apparaître le menu de la fenêtre. Utilisée dans Blender, la combinaison de touches lance le raccourci Ubuntu, rendant inopérant celui de Blender. Pour résoudre ce problème, soit on modifie le raccourci dans Blender, soit on modifie celui dans Ubuntu (l'un OU l'autre, bien sûr). On peut par exemple remplacer l'un des 2 raccourcis par SUPER + clic droit.

  • pour changer le raccourci dans Ubuntu : installer compizconfig-settings-manager (voir la page compizconfig-settings-manager). Cliquer sur General, puis Options Générales, onglet Assignation de touches. Le raccourci à changer se nomme "Menu de la fenêtre" pour ALT + clic droit, et Menu de la fenêtre pour Ctrl + Alt + S. Attention si vous utilisez Gnome-Shell sur Ubuntu 12.04, vous serez peut-être obligez de passer sous Unity pour que le changement de raccourcis soit possible et effectif.
  • pour changer le raccourci dans Blender : cliquer sur File > User Preferences…, onglet Input. Développer 3D View > Mesh. Le raccourci à changer se nomme "Loop Select"

A noter : l'utilisation de ALT + SHIFT + clic droit permet d'ajouter à la sélection courante, alors que le ALT + clic droit définit cette sélection indépendamment de ce qui était sélectionné précédement. Dans la pratique on peut donc tout à fait utiliser ALT + SHIFT + clic droit pour remplacer le ALT + clic droit sans avoir de conflit avec Ubuntu.

Improviser une ferme de rendu pour une animation

Comme certaines scènes sont très complexes à rendre, on a recours à ce qu'on appelle une ferme de rendu. Il s'agit d'un groupe d'ordinateurs en réseau qui se partagent le calcul d'un rendu d'une scène en 3D (cela ne se limite pas à la 3D mais restons-en là). C'est comme ça que sont rendus les films d'animation Pixar ou DreamWorks par exemple. Chez les pros, ces fermes se présentent sous la même forme que des serveurs en racks. De cette manière, les temps de rendus sont extrêmement raccourcis et ne se font plus "à l'échelle des temps géologiques" comme sur un simple ordinateur de bureau.

Malheureusement, vous vous en doutez, il n'est pas donné à tout le monde de s'acheter 100 racks avec des Doubles Quad-Core dernier cri ; ou même de s'offrir les services des gens qui proposent de rendre vos scènes sur leur ferme. Heureusement vous vous rendez compte (et c'est peut-être pour ça que vous êtes ici) que vous avez quelques PCs inexploités à la maison ! Il vous faut créer votre ferme de rendu !

DrQueue

Pour cela il existe un logiciel qui semble fait pour ça : DrQueue. Le problème c'est que sa mise en place peut s'avérer ardue quelques fois. Aussi l'ami Blender peut vous aider à vous en passer.

Mise en réseau

  • Il faut tout d'abord mettre correctement vos machines en réseau (Linux, Windows, Mac, Irix et Solaris confondus, tant que Blender se lance dessus). Je vous renvoie aux divers articles sur le sujet : réseau.
  • Ensuite partagez un dossier de la machine maîtresse qui contiendra votre fichier .blend ET vos images rendues (de préférence dans un sous-dossier). Dossier dont vous aurez pris soin de laisser la permissions aux autres machines (utilisateurs) de lire et écrire dedans. partage
  • Sur chaque machine, faites que le dossier partagé fasse partie de l'arborescence du système (Windows : "Connecter un lecteur réseau" est une bonne solution - Ubuntu : Ouvrir le dossier suffit amplement).
  • Installez et paramétrez (si besoin) Blender 3D. (Sinon utilisez les versions sans installation) Utilisez la même version que celle que vous utilisez, ou plus récente, pour éviter les problèmes. (La dernière version est un excellent choix)

Adaptation du fichier .blend

  • Retournez sur votre PC maître et ouvrez votre scène avec Blender. Vérifiez que tous vos paramètres "esthétiques" sont bons (dimensions, nombre d'images, mouvements, etc).
  • Ensuite, convertissez vos "Fonts" en "Meshes", incluez vos textures au .blend, sauf si le chemin est relatif au dossier de partage. (Textures et Fontes dans le dossier partagé)
  • Enfin dans l'onglet rendu, entrez un chemin de sauvegarde des images avec une adresse absolue vers le dossier "Rendu" contenu dans le dossier partagé. (Vous adapterez selon les machines et leurs OS) Rendez vos images en images (PNG, JPEG, TIFF).
  • La dernière touche qui fait la magie du système c'est de cocher "Touch" et "NoOverwrite". "NoOverwrite" fait en sorte que Blender ne rende QUE les images qui n'ont pas encore été rendues. De son côté, "Touch" évite de calculer la même image sur deux PCs différents. En effet, Blender n'écrit un fichier (image) que lorsqu'il a finit de calculer cette image. Or pendant le temps du calcul de cette image, une autre machine croit que l'image n'est pas encore rendue et elle se met à la calculer aussi. On se met alors à perdre du temps précieux.
  • Sauvegardez votre fichier adapté et fermez Blender.
  • Copiez votre fichier dans le dossier partagé (avec ses dépendances s'il y en a).

Rendu collectif

  • Sur chaque machine, lancez Blender et ouvrez le fichier à rendre.
  • Adaptez si besoin l'adresse du répertoire de sauvegarde des images.
  • Lancez le rendu ! (En fin de calcul, pensez à relancer le rendu sur un PC pour vérifier)

Après le rendu

  • Déjà fini ? Eh bien maintenant si vous souhaitez faire de votre séquence d'image une vidéo : utilisez Blender pour "lier" vos images au sein d'un seul fichier *.avi ou *.mpeg ou autre !
  • Sinon, vous pouvez toujours utiliser un logiciel extérieur tel Avidemux.

Le projet BURP avec BOINC

Un projet BOINC est en train de voir le jour. Il s'agit d'une ferme de rendu mutualisé, appelée BURP (Big and Ugly Rendering Project, comprenez Projet de rendus énorme et laid :P). Il est pour le moment disponible en Bêta et peut donc souffrir de bugs et de limitations. Le site du projet : http://burp.renderfarming.net/.

Effets Spéciaux

Blender peut aussi permettre de faire des effets spéciaux. Voir en video

Fichiers d'effets :

Tutoriel blender :

Solution calcul distribué :

Tutoriel matériel :

Tutoriel non spécifique a blender :

Blender Game Engine, moteur de jeu

Blender Game Engine ou BGE, est un des moteurs de jeu libre les plus évolués ( programmation graphique et par script python, lua ). Il s'intégre aussi dans une page web, pour créer des jeux rapides et de qualité par une extension de navigateur : Buster

Présentation : Voir des vidéos de martin pour la toute dernière version de blender game Engine, avec un niveau de réalisme digne des moteurs temps réel payants ( crisis , unity, etc. ) :

Blender Game Engine est un moteur de jeu vidéo, utilisé notamment dans le jeu yo_frankie et d'autres.

Voir aussi developpement_de_jeux_video

Liens

Ressources

Tutoriel

Documentation



Le contenu de ce wiki est sous licence : CC BY-SA v3.0