Contenu | Rechercher | Menus

 Logo de Gimp

GIMP

Capture d'écran de Gimp

GIMP, acronyme de « GNU Image Manipulation Program », est un logiciel libre de dessin matriciel.

Il vous permet de dessiner, peindre et éditer des images.

  • Plusieurs des outils et des greffons (plugins) disponibles dans GIMP sont semblables à ceux d'Adobe Photoshop, ou d'autres éditeurs d'image.
  • GIMP est également compatible avec l'ensemble des extensions de fichier1), et de leur format respectif dont les PSD, PSP, FLI, FLC, PDF
  • GIMP permet d'utiliser des scripts pour les opérations et les manipulations d'images compatibles avec les langages libres de scripts-fu2).
  • Enfin, ce qui fait la force de GIMP, c'est la communauté qui le supporte : la quantité du contenu libre pour GIMP (les scripts, les tampons, motifs, brosses, etc …) est incommensurable. De plus GIMP est également compatible avec le contenu (les brosses, etc…) de Photoshop3).

La seule difficulté pour un passage de Photoshop à GIMP, c'est d'accepter de prendre le temps de découvrir un bon logiciel qu'on ne connaissait pas avant, et qui sur certains points peut être supérieur à Photoshop ou inférieur sur d'autres (mais ça avance !).

GIMP permet la lecture et l'écriture dans une grande variété de formats, y compris dans une certaine mesure les formats propriétaires tels que ceux d'Adobe Photoshop (fichiers PSD). Le support des scanners et des imprimantes est également disponible. Il y a beaucoup d'autres outils pour le traitement d'images couvrant une grande gamme de formats, bien que GIMP soit une des rares applications qui présente ses outils et ses fonctionnalités par une interface utilisateur graphique semblable dans les différentes plateformes.

Installation

GIMP n'est plus installé par défaut depuis Ubuntu 10.04 LTS, mais reste présent dans les variantes Xubuntu et Ubuntu Studio.

Pour installer le logiciel GIMP, il suffit d'installer le paquet gimp.

Si vous êtes sous Kubuntu, il se peut que vous ayez à installer les paquets language-pack-gnome-fr language-pack-gnome-fr-base gimp-help-fr pour avoir GIMP en français.

Dans un terminal :

sudo apt-get install language-pack-gnome-fr language-pack-gnome-fr-base gimp-help-fr 

Pour disposer des dernières versions

Vous pouvez installer GIMP à partir d'un dépôt PPA pour disposer d'une version plus récente, s'il y en a.

Version Ubuntu Version installée Version du PPA
Ubuntu 13.04 2.8.4 2.8.6
Ubuntu 12.10 2.8.2 2.8.2
Ubuntu 12.04 LTS 2.6.12 2.8.6
Ubuntu 11.10 2.6.11 2.9.1

Ou lancer les commandes ci-dessous dans un terminal:

sudo add-apt-repository ppa:otto-kesselgulasch/gimp && sudo apt-get update && sudo apt-get install gimp

Utilisation (prise en main)

Nous allons vous présenter très rapidement divers outils et dialogues de base. Lisez la section « Voir aussi » en fin de page pour trouver des sites spécialisés vous permettant d'apprendre à utiliser correctement GIMP.

Les outils de base

Les outils de sélection

Les 6 premiers outils disponibles (en partant d'en haut à gauche) sont des outils de sélection. Certainement les outils les plus importants de GIMP. C'est avec eux que vous ferez le plus de choses. Une bonne maîtrise de ces outils est indispensable si vous comptez vous lancer dans l'apprentissage de GIMP. Ces outils de sélections possèdent de nombreuses options modulables. Dans l'ordre d'apparition, nous avons (les lettres entre parenthèses sont les touches de raccourcis correspondantes) :

  • Sélection rectangulaire (R)
  • Sélection elliptique (E)
  • Sélection à main levée (appelée "sélection lasso") (F)
  • Sélection baguette magique (Z U)
  • Sélection par couleur (Shift + O)
  • Sélection par ciseaux magiques (I)

Il vous faudra un certain temps pour apprendre à vous servir correctement de chacune de ces sélections. Mais pour un usage basique, vous arriverez très vite à un résultat satisfaisant !

Mise en pratique
  1. Créez un nouveau document (Fichier - Nouveau)
  2. Choisissez l'outil "Sélection rectangulaire".
  3. Sur le nouveau document, cliquez-glissez votre pointeur, tout en appuyant sur la touche Shift, ce qui a pour conséquence de forcer la sélection à garder une forme "carrée". Relâchez. La zone de sélection apparaît alors sous la forme de "fourmis en marche" (des petits traits noirs et blancs).
  4. Choisissez l'outil "pot de peinture" (Shift + B) et cliquez à l'intérieur de cette zone. Vous venez de colorier un carré.

Quelques autres outils

Vous n'aurez que peu de soucis pour comprendre le fonctionnement des autres outils. Certains outils, tels la gomme, l'aérographe ou l'outil de découpe, sont assez faciles à utiliser. Même si les possibilités offertes par chacun de ces outils sont décuplées par la modification de leurs options. Pour accéder aux options d'un outil, double-cliquez sur l'icône de celui-ci.

Les boîtes de dialogue de base

Toutes les boîtes peuvent être regroupées entre elles sous forme d'onglets. Pratique pour éviter de se retrouver avec 15 boîtes de dialogue ouvertes.

La boîte "calque"

Cette boîte permet de travailler sur des calques (couches) différents, de les organiser, de les sélectionner et de leur appliquer un effet. Boîte de dialogue accessible à partir du menu Dialogues - calques.

La boîte "options des outils"

Cette boîte est différente pour chaque outil. Contient de nombreuses variables.

La boîte "Brosses"

Vous permettra de choisir une brosse pour le dessin, et même en créer de nouvelles facilement. Vous trouverez via l'url ci-dessous la documentation concernant l'ajout de brosse http://docs.gimp.org/fr/gimp-using-brushes.html Depuis Gimp 2.6, les brosses Photoshop sont compatibles avec Gimp, ce qui agrandi la bibliothèque de brosses de manière très conséquente ;)

Les filtres

Par l'intermédiaire du clic droit, ou du menu "Filtres", vous aurez accès à une tonne de filtres de modifications. Flouter une image, la coloriser, lui donner un aspect "vieux journal", un effet de vitesse, améliorer les tracés, tracer des figures géométriques, ajouter une source de lumière… Des dizaines de filtres sont préinstallés. La plupart des filtres sont personnalisables, certains sont même entièrement paramétrables !

Avertissement aux utilisateurs de Photoshop: Les fenêtres

La version 2.8 stable est sortie le 3 mai 2012, elle permet dorénavant de choisir le mode « Fenêtre unique » (dans le menu "fenêtre")

Pour ceux qui regretteraient la fonction "tons clairs / tons foncés" de Photoshop, il y a un équivalent sous Gimp : Clairs & Obscurs

Utilisation avancée

Astuces

GEGL est une nouvelle fonctionnalité qui se trouve dans GIMP 2.6 +. : Selon Gimp.org:

«Beaucoup de fonctionnalités très demandées de GIMP seront plus faciles à intégrer en utilisant GEGL. Les effets de calque, les groupes de calques, et des réglages de calque sont facilement mise en place (et efficacement calculés) à l'aide de l'organisation DAG de GEGL. Le modèle de couleur CMYK et un meilleur rendu des bits, seront plus facile puisque GEGL ne prend pas les mêmes hypothèses sur les espaces de couleurs avec les types de données que ceux de Gimp. "

Il n'est pas activé par défaut. Pour activer la fonction, naviguer simplement à Couleurs > Utiliser GEGL et cochez la case à côté. Une fois qu'il est activé, vous pouvez utiliser les pré-réglages disponibles au Centre d'exploitation Outils → Action GEGL. Plus d'une vingtaine d'actions différentes peuvent être appliquées aux calques et aux images.

Fixer facilement les fenêtres de façon pratique

  • Allez dans Édition → Préférences → Gestion des fenêtres
  • Sélectionnez pour la boîte à outil et les autres groupes de fenêtres : fenêtre utilitaire puis validez et redémarrez The Gimp.
  • Ainsi les boîtes à outils resteront au dessus de l'image tout en étant en dessous des autres fenêtres ouvertes

Optimiser la sauvegarde d'un jpeg afin d'obtenir un meilleur rapport de compression pour le web

  • réduire la taille de l'image
  • enregistrer avec un taux de compression compris entre 0.65 et 0.8
  • sous Options avancées, cocher l'option Progressif.

Voir ce tutoriel.

Optimiser la sauvegarde d'un png

Scanner une image

Pour numériser une image directement depuis The Gimp, allez dans le menu Fichier > Créer > XSANE > Device Dialog.

Greffons

Un greffon (ou plugin) est un programme supplémentaire (et optionnel) que l'on peut ajouter à un logiciel pour lui ajouter une ou plusieurs fonctions.

Vous pouvez installer des suppléments officiels en installant les paquets gimp-data-extras gimp-plugin-registry.

Photographie :

Ajout de fonctionnalités :

Édition d'image :

  • SIOX : outil de détourage, et d'extraction, impressionnant. Il est intégré à Gimp depuis la 2.6.8 dans la boîte à outil sous le nom "outil d'extraction du premier plan".
  • Liquid Rescale : changer les proportions de l'image sans distorsion (voir les exemples vidéos).
  • GAP, GIMP Animation Package : pour faire des animations, avec des effets étonnants.(installer), permet également de faire du morphing.

Réflexion ( souvent utilisé pour embellir rapidement des images ) :

Pour designer :

→ Pour plus de greffons et de plugins regarder les ressources.

Annexe :

  • PSPI: Implémenter les plug-ins Photoshop dans GIMP, nécessite Wine.

Gnome Global Menu

GIMP est compatible avec globalmenu, qui vous permet de gagner en espace d'édition en déplaçant le menu comme sous Mac OS X.

Variantes

  • Gimp Painter: Variante de GIMP lui rajoutant l'outil mix-brush pour la peinture numérique.

Tutoriels

Configuration

Créer un profil de couleur écran pour Gimp

Pour que Gimp affiche avec justesse les couleurs des photos et montages graphiques dans lesquels vous travaillez, il est primordial de créer un profil de couleur avec une sonde et de l'activer dans les préférences de Gimp. Pour cela, référez-vous à cette documentation: dispcal_gui

Voir aussi

Ressources

Avoir à sa disposition une collection de brush est un bon point de départ.

Des brushs sur :

DeviantArt :

Les plugins :

Des thêmes :

  • Photoshop CS6(Thême Gtk créé par Jays-Artist (gnome-look.org) et modifié par BloodyOrigami)
  • Photoshop CS5(Thême Gtk créé par doctormo (DeviantArt) et modifié par BloodyOrigami)

Documentation

Cette page n'a aucune autre prétention que de vous présenter brièvement le logiciel GIMP. Il est strictement impossible d'explorer toutes les possibilités de GIMP en quelques lignes… Si vous désirez aller plus loin que la simple retouche de photo « amateur », ou le simple dessin « façon MS Paint » (ce qui n'a absolument rien de péjoratif), il vous faudra vous documenter plus avant. Même si vous vous sentez l'âme d'un autodidacte, vous risquez de passer à coté de fonctions surprenantes si vous ne faites pas un effort de documentation. Voici quelques sites qui vont vous apporter une aide précieuse :

  • Documentation officielle, en français — Extrêmement complète. Détaille toutes les fonctionnalités de GIMP.
  • gimpfr.org — Site en français très complet, axé sur l'actualité de GIMP ; de nombreuses ressources (tutoriels, brosses, scripts…) sont également disponibles.
  • Livre libre en français pour apprendre simplement les principales fonctions du logiciel GIMP pour la retouche photo débutant, fait par Flossmanuals francophone et l'Association francophone des graphistes libres.
  • GIMPons — Site en français référençant des centaines de tutoriels sur GIMP tous sélectionnables grâce aux images (avant et après le traitement d'image). Il explique, toujours en images, les filtres de GIMP et fournit les paramètres de ceux-ci. Tous les tutoriels sont rangés par catégories (boutons, textes, effets sur images effets sur corps humain, etc.).
  • Le mini-site GIMP sur LinuxGraphics — Il inclut également un des forums francophones les plus actifs sur le sujet.
  • Virus photo — Quelques tutoriels vidéo sur Gimp.
  • Calcyum.org — Site francophone pour les infographistes qui font appel ou souhaitent faire appel aux logiciels libres dans un cadre aussi bien professionnel que non professionnel. (a priori le site n'existe plus)

Tutoriels


Contributeurs : Tramway, Barbatruk_tho, Pika3D.


gimp.txt · Dernière modification: Le 23/03/2014, 09:30 par BloodyOrigami
Le contenu de ce wiki est sous licence : CC BY-SA v3.0