Contenu | Rechercher | Menus

Logiciels

Voir la page Gestionnaire de photos.

Téléchargements

Téléchargement depuis bureau ordinateur

Le protocole de communication entre l'ordinateur et l'appareil photo varie d'un appareil à l'autre. Pour faire simple il y a 3 catégories :

  • UMS (USB Mass Storage) : l'appareil se comporte comme une simple clé USB ou un disque dur externe et utilise en général un système de fichier FAT32 (parfois FAT16) ;
  • PTP (Picture Transfert Protocol) : est le protocole standard de communication et de pilotage des appareils photo. Malheureusement certains fabriquants ont une interprétation bien à eux de ce protocole ;
  • Protocole spécifique : ce n'est presque plus le cas aujourd'hui mais par le passé certains appareils utilisaient des protocoles spécifiques.

Dans les 2 derniers cas il faut passer par GPhoto pour extraire les photos de l'appareil. Il existe un modèle générique USB PTP pour les appareils supportant le protocole PTP standard et des variantes spécifiques.

Attention, il existe actuellement (note de 2007, liée à Feisty probablement obsolète) un bug sous certains appareil photo numériques branchés via un port USB qui empêche toute connexion de l'appareil. En attendant une correction, vous pouvez installer une ancienne version du paquet libgphoto2-2 en suivant cette procédure expliquée sur le forum.

Il existe des interfaces graphiques pour simplifier la rapatriement des photos de l'appareil sur l'ordinateur :

La plupart des appareils sont automatiquement détectés une fois branchés. Il suffit ensuite de suivre les informations qui s'affichent à l'écran. Pour passer de F-Spot à gThumb et réciproquement en tant qu'interface graphique de rapatriement des photos sous Ubuntu 8.04:

  • Aller dans Système / Préférences / Périphériques et média amovibles, dans le premier onglet "Appareil photo et caméscope" ;
  • Entrer dans le champ Commande "f-spot-import" ou "gthumb –import-photos" (attention, 2 '-' devant import-photos) selon l'interface souhaitée.
  • Sous Kubuntu/KDE :
    • Konqueror : il gère très bien l'UMS par défaut, pour les autres protocoles, il faut :
      1. Lancer le Centre de configuration KDE (kcontrol) ;
      2. Choisir dans l'arbre de navigation Périphériques → Appareil photo numérique ;
      3. Ajouter l'appareil photo numérique à condition que le modèle soit reconnu par GPhoto2 ;
      4. Lancer Konqueror et saisir l'URL media:/ l'appareil photo apparaît. Remarque : sous KDE4, il faut saisir l'URL camera:/ et non plus media:/ ;
    • DigiKam :
      1. Pour ajouter un appareil photo GPhoto2 utiliser le menu Appareil photo → Ajouter ;
      2. Pour rapatrier les photos d'un appareil, sélectionner l'appareil par son nom dans le menu Appareil photo.

Téléchargement depuis un appareil photo numérique en ligne de commande.

Grâce à la documentation du site de Gphoto :

  • Sous Ubuntu/Gnome ;
  1. Brancher l'appareil photo sur un port Usb ;
  2. Il apparait sur le bureau et/ou dans les volumes ;
  3. Clique droit dessus : le démonter ;
  4. Ouvrir un terminal dans le dossier où vous souhaitez importer vos photos/films ;
  5. En tant que simple utilisateur, lancez dans le terminal : gphoto2 –list-files ( Cette commande donne le contenu de l'appareil photo.) ;
  6. puis : gphoto2 –get-all-files ( qui importe vos documents, films - photos… ) ;
  7. Vous pouvez débrancher l'appareil photo du port Usb.

Dérawtisation

Certains appareils photo (vers le haut de gamme) produisent des images dans un format brut (aucune transformation par l'appareil photo). C'est une sorte de négatif numérique qu'il faut "développer", c'est à dire choisir des paramètres de rendus, pour obtenir une image classique. Ce format d'image contient exactement les données perçues par le capteur de l'appareil et donc le maximum de détails. Malheureusement chaque fabriquant utilise son propre format de données.

Vous trouverez plus d'informations sur la page Raw, dans la partie : Édition des fichiers raw.

Numérisation avec un scanner

Il existe de nombreux logiciels de scan. Les plus courants sont xsane (installé de base sous Ubuntu), GnomeScan ou encore gscan2pdf qui permet de créer des PDFs à partir de scans.

Pour de plus amples informations, rendez-vous sur la page relative à l'utilisation d'un scanner.

Couleurs

Luminosité, contraste, exposition

Vous avez une photo sous/sur exposée et vous aimeriez corriger l'exposition.

Pour faire simple, il y a 3 familles d'outils qui font sensiblement la même chose :

  • Luminosité/contraste : qui permet d'éclaircir/assombrir/contraster/adoucir une image ;
  • Niveaux : qui permet d'afficher un histogramme représentant la quantité des teintes claires/moyennes/foncées et de réduire/agrandir la place, l'importance qui leur est donnée dans l'image ;
  • Niveaux automatiques : automatise le traitement basé sur l'histogramme.

Les outils :

  • Sous Ubuntu/Gnome :
    • GIMP :
      • menu Calque → Couleurs → Luminosité - contraste ;
      • menu Couleurs → Coloriser ;
      • menu Couleurs → Niveaux ;
      • menu Couleurs → Courbes ;
      • menu Couleurs → Auto (nombreux outils automatiques) ;
    • F-Spot : outil Ajuster les couleurs ;
    • G-Thumb : menu Image → Luminosité - Contraste ;
  • Sous Kubuntu/KDE :
    • Editeur d'images DigiKam : menu Corriger → Couleurs → Luminosité, contraste, gamma
    • Krita :
      • menu Filtre → Ajuster → Luminosité, contraste ;
      • menu Filtre → Ajuster → Niveaux ;
      • menu Filtre → Ajuster → Contraste automatique ;

Noir et blanc

Vous souhaitez transformer un photo couleur en noir et blanc ou sépia.

La plupart des outils propose une fonction pour "désaturer" une image en faisant la moyenne des tons rouges, verts et bleus. Il peut être intéressant de pondérer différemment chaque composante RVB pour obtenir un noir et blanc différent. Enfin le blanc peut tirer vers le jaune orangé (sépia) pour vieillir une photo ou d'autres couleurs pour produire des effets créatifs (le bleu pour refroidir une photo par exemple).

Les outils :

  • Sous Ubuntu/Gnome :
    • GIMP :
      • menu Calque → Couleurs → Désaturer ;
      • menu Couleurs → Coloriser ;
      • menu Couleurs → Composants/Mixeur de canaux, cocher la case Monochrome ;
    • F-Spot :
      • menu Outil → Convertir en Noir & Blanc ;
      • menu Outil → Convertir en Sépia ;
    • GThumb : menu Image → Désaturer ;
  • Sous Kubuntu/KDE :
    • Editeur d'images DigiKam :
      • menu Corriger → Couleurs → Mixer les canaux de couleurs, cocher la case Monochrome ;
      • menu Filtres → Noir & blanc automatise la conversion en noir et blanc, sépia….

Yeux rouges

Sous l'effet d'un coup de flash direct, les yeux d'une personne sont devenus rouges.

Il faut en général sélectionner la zone à corriger (l'œil) puis appliquer un filtre dans lequel on peut doser l'intensité de la correction.

Les outils :

  • Sous Ubuntu/Gnome :
    • Gthumb: menu Images → Correction yeux rouges, 1 clic sur la pupille suffit. Correction basique, convient aux débutants ;
    • Fspot: menu Outil → Réduction des yeux rouges, sélectionner un œil puis valider. Correction basique, convient aux débutants ;
    • Gimp : sélectionner uniquement la pupille (sans l'iris, donc sélection ovale), aller dans le menu Filtres → Améliorations → Suppression des yeux rouges. Possibilité d'affiner la correction. Voir aussi ce tuto pour une correction pro ;
  • Sous Kubuntu/KDE :
    • Éditeur d'images DigiKam : menu Corriger → Yeux rouges.

Vignettage

Certains objectifs assombrissent plus ou moins fortement l'image dans les coins, en particulier lorsqu'ils sont utilisés à pleine ouverture.

Les outils :

  • Sous Ubuntu/Gnome :
    • GIMP : menu Filtres → Distorsion → Wideangle grâce au plugin Wide angle et utiliser le paramètre brighten ;
  • Sous Kubuntu/KDE :
    • Editeur d'images de Digikam : menu Corriger → Corriger les vignettage ;
    • Krita : menu Filtres → Autres → Lens correction et utiliser le paramètre correction de la luminosité (brightness correction).

Géométrie

Redimensionnement

Le redimensionnement, ou la mise à l'échelle, est une transformation applicable à une image numérique qui consiste à en modifier la taille, que ce soit pour l'agrandir ou pour la rétrécir, comme le ferait un zoom. Il permet aussi de réduire son poids (en Mo), afin par exemple de l'envoyer par email ou sur un site de développement photo.

Les outils :

  • Sous Ubuntu/Gnome :
    • Nautilus : clic-droit sur les images → Redimensionner les images… (après avoir installé nautilus-image-converter) ;
    • GIMP : menu Image → Échelle et taille de l'image… ;
    • GThumb : menu Outils → Redimensionner les images… ;
    • Picture Toolbox: menu Traitement en masse → Redimensionnement… ;
  • Sous Kubuntu/KDE :
    • DigiKam :
      • image par image : menu Image → Modifier… (F4) qui ouvre l'Éditeur d'image, puis menu Transformer → Redimensionner… ;
      • traitement par lots : menu Traitement par lots → Redimensionner des images… ;
    • Krita : menu FIXME.

Rotation à 90°

Vous avez pris une photo avec un orientation "Portrait", mais votre ordinateur vous la présente avec un orientation "Paysage".

Tous les outils proposent un rotation à 90° qui peut se faire sans perte de qualité :

  • Sous Ubuntu/Gnome :
    • Nautilus : clic-droit sur les images → Pivoter les images… (après avoir installé nautilus-image-converter) ;
    • GIMP : menu Calque → Transformer → Rotation 90°… ;
    • F-Spot : menu Outil → Rotation à droite/gauche ;
    • GThumb : menu Image → Transformer → Rotation à droite/gauche ;
  • Sous Kubuntu/KDE :
    • DigiKam : menu Image → Rotation → 90/270° ;
    • Editeur d'images DigiKam : menu Transformer → Rotation → 90/270° ;
    • Krita : menu Calque/Image → Tourner → Tourner le calque/l'image CW/CCW.

Rotation libre

Vous aviez bu ;-) ce jour là et du coup l'horizon ou un bâtiment n'est pas droit.

Les outils :

  • Sous Ubuntu/Gnome :
    • GIMP : menu Calque → Transformer → Rotation arbitraire… ou bien outil → Rotation arbitraire ;
    • F-spot : Redressement
  • Sous Kubuntu/KDE :
    • Editeur d'images DigiKam : menu Transformer → Rotation libre ;
    • Krita : menu Calque/Image → Tourner → Tourner l'image.

Recadrage

Vous voulez découper la photo pour éliminer une zone en périphérie ou zoomer sur un détail.

Il peut être important de vouloir conserver un ratio hauteur/largeur de 2/3 (standard argentique) ou 3/4 (standard numérique) ou autre…

Les outils :

  • Sous Ubuntu/Gnome :
    • GIMP : Outil → Découpage (fige le ratio librement) ;
    • F-Spot : Outil → Découpage/Rogner (peut figer le ratio) ;
    • GThumb : menu Image → Découpage/Rogner (peut figer le ratio) ;
  • Sous Kubuntu/KDE :
    • Editeur d'images DigiKam : menu Transformer → Recadrer selon un ratio ;
    • Krita : Outil → Rogner.
  • cadreuse, logiciel écrit en C

Perspective

Les fuyantes d'un bâtiment ou d'une avenue prennent trop d'importance dans la photo, vous pouvez corriger la perspective.

Les outils :

  • Sous Ubuntu/Gnome :
    • GIMP : Outil → Perspective ;
  • Sous Kubuntu/KDE :
    • Editeur d'images DigiKam : menu Transformer → Ajuster la perspective ;
    • Krita : Outil → Perspective.

Déformation en coussinet ou barillet

Les objectifs déforment plus ou moins fortement l'image, et particulièrement les zooms utilisés à leurs focales extrêmes :

  • un grand angle (extension minimale du zoom) produit une déformation en barillet ou convexe ;
  • un télé-objectif (extension maximale du zoom) produit une déformation en coussinet ou concave ;

Cette déformation qui transforme les lignes droites en courbes peut se corriger.

Les outils :

  • Sous Ubuntu/Gnome :
    • GIMP : menu Filtres → Distorsion → Wideangle grâce au plugin Wide angle ;
  • Sous Kubuntu/KDE :
    • Editeur d'images de Digikam : menu Corriger → Corriger la déformation due à l'objectif ;
    • Krita : menu Filtres → Autres → Lens correction.

Autre

Gommer un détail

Vous voulez faire disparaître un détail ingrat sur une photo.

Il y a plusieurs techniques pour arriver à ses fins :

  • Recouvrir le détail par une portion proche de la même image (outil tampon) ;
  • Utiliser un algorithme d'inpainting comme celui fourni par la librairie GREYCstoration.

Les outils :

  • Sous Ubuntu/Gnome :
    • GIMP : Outil → Clôner (Tampon) ;
    • Ou mieux encore GIMP : Outil → Correcteur(Sparadrap) depuis Gimp 2.4 ;
  • Sous Kubuntu/KDE :
    • Krita : Outil → Dupliquer (Tampon) ;
    • Digikam: menu Améliorer → Gommer une partie non désirée (in-painting) ;

Bruit

Quand il n'y a pas assez de lumière les capteurs des appareils photo ont tendance à produire du bruit. Cela se traduit par un moutonnement disgracieux dans les zones unies (ciel…). Le problème est que si on uniformise trop l'image on détruit des détails et elle devient floue. Il existe néanmoins différents algorithmes pour réduire le bruit.

Les outils :

  • Sous Ubuntu/Gnome :
    • GIMP :
      • menu Filtre → Amélioration → Anti parasites ;
      • menu Filtre → Amélioraion → Dcam Noise grâce au plugin Dcam noise ;
      • menu Filtre → Misc → GREYCstoration avec le plugin GREYCstoration ;
  • Sous Kubuntu/KDE :
    • Editeur d'images de Digikam : menu Corriger → Réduire le bruit ;
    • Krita :
      • menu Filtre → Augmenter → Restauration d'image CIMG ;
      • menu Filtre → Augmenter → Réduction du bruit Gaussien ;
      • menu Filtre → Augmenter → Réduction du bruit par ondelette.

Création d'une mosaïque d'images ressemblant à une image particulière

Voir le petit logiciel metapixel qui est prévu à cet effet.

Création d'image HDR ou HDRI

  • Qtpfsgui : logiciel libre de création d'image HDR (High dynamic range imaging ou HDRI)

Amusant : effets sur le corps humain

Voir cette page.

Traitement par lots

Avec une interface graphique :

  • phatch : logiciel complet et ergonomique, dans les dépôts ;
  • Picture Toolbox : Logiciel qui permet bon nombres d'opérations, dont la visualisation des données EXIF.
  • gthumb : a quelques fonctionnalités ;
  • convertit : permet de commander imagemagick, et donc de faire ce qu'on veut en rajoutant des fonctions ;
  • Xnview-MP : de nombreuses options dans "Multi Convert" ;
  • gwenview : logiciel de visualisation d'image de KDE qui permet des traitements par lots très fonctionnels et complets.
  • digikam : nouvelle interface (v1.2) pour les traitements par lot, avec gestion des files d'attentes, et multiples opérations possibles.

En ligne de commandes :

Sortie/exploration des images/photos

Création d'un diaporama de photos

Consultez la page diaporama qui recense les logiciels gérant cette fonctionnalité.

Générer un album web statique

J'appelle album web statique un mini site web, autrement dit un ensemble de pages HTML et d'images (planches contacts et photos plein format), qui n'utilise pas de CGI/PHP/ASP/JSP… On n'a donc pas besoin d'un serveur web (comme Apache) pour le visualiser, un simple navigateur suffit.

Ce type d'album Web est facile et rapide à mettre en place sur votre page personnelle hébergée par votre fournisseur d'accès à Internet. On peut aussi s'en servir pour présenter des photos sur un CD/DVD.

Par contre chaque ajout ou modification d'une photo nécessite habituellement de générer à nouveau l'album dans sa totalité.

Les outils :

  • Sous Ubuntu/Gnome :
    • Gthumb : Outils → Créer un album web ;
    • F-Spot : menu Fichier → Exporter → Exporter dans un Dossier ;
    • JBrout : grâce au plugin Export to HTML ;
  • Sous Kubuntu/KDE :
    • Digikam et Gwenview : grâce au plugin Kipi HTML Gallery ;
  • Autres :
    • JAlbum est une application Java dédiée à la génération d'album web statiques ;
    • bins est une application qui génère un album photo à partir des photos et d'un fichier XML de description. Elle s'utilise essentiellement en ligne de commande, même si un outil graphique est fourni ;

Exporter vers album web dynamique

J'appelle album web dynamique un album qui s'appuie sur un serveur web pour présenter une collection de photos. Je pense par exemple à :

Des albums mettent en œuvre des scripts CGI/PHP/ASP/JSP… et bien souvent une base de données (MySQL…). L'ajout d'une photo dans la collection se fait grâce au site web lui même. Les photos peuvent aussi parfois être rajoutées via FTP. Les visiteurs peuvent parfois noter et/ou commenter vos photos.

Les outils :

  • Sous Ubuntu/Gnome :
    • F-Spot : menu Fichier → Exporter → Exporter vers Flickr/Web Gallery/Picasaweb ;
  • Sous Kubuntu/KDE :
    • Digikam et Gwenview : grâce aux plugins Kipi Flickr export et Gallery export ;

Archiver sur un CD ou un DVD

Vous souhaitez faire mettre vos photos sur un CD ou DVD pour en faire une copie de sauvegarde ou les offrir à votre grand-mère (qui est geek comme vous).

Les outils :

  • Sous Ubuntu/Gnome :
    • F-Spot : menu Fichier → Exporter → Exporter sur un CD ;
  • Sous Kubuntu/KDE :
    • Digikam et Gwenview : grâce au plugin Kipi CD Archiving et à K3b ;

Imprimer

Vous voulez tirer vos photos sur une imprimante à jet d'encre spéciale pour la photo ou pas.

Il faut commencer par installer le pilote et configurer la dite imprimante.

A finir

Impression de photos par lot (avec le logiciel F-spot)

  1. Mettre toutes les photos à imprimer dans un dossier que l'on renommera A ;
  2. Lancer F-spot ;
  3. S'il y a des photos en attente, les supprimer en faisant : Edition / Tout sélectionner / Edition / Enlever du catalogue ;
  4. Importer le dossier A en faisant : Photo / Importer ;
    • Dans la fenêtre qui s'ouvre, sélectionner le dossier A, puis l'ouvrir ;
    • Cliquer sur Importer.
  5. Sélectionner les photos fraichement importées en faisant : Edition / Tout sélectionner, puis : Photo / Imprimer / Imprimer dans un fichier ;
  6. Choisir le dossier de sortie (par exemple bureau)
  7. Imprimer
  8. Récupérer le fichier PDF dans le dossier de sortie, (dans notre exemple bureau).
  9. Ouvrir le fichier PDF pour l'imprimer sur papier avec l'imprimante en service

Envoyer par e-Mail

Vous souhaitez envoyer des photos par e-Mail. Vu la taille des fichiers (plusieurs Mo) produits par les appareils photo récents (plusieurs Mpx), il est conseillé/exigé de les réduire pour éviter d'encombrer la boîte aux lettres du destinataire. Pour celà il faut transformer les images en réduisant leur résolution et augmentant le taux de compression.

Les outils :

  • Sous Ubuntu/Gnome :
    • F-Spot : menu Fichier → Envoyer par Mail ;
    • Mailpictures : extension en français de Nautilus très pratique, très intuitive, et paramétrable pour une utilisation extrêmement simple (voir ce post du forum) ;
  • Sous Kubuntu/KDE :
    • Digikam et Gwenview : grâce au plugin Kipi Send images et à KMail ;

Problèmes et solutions

Nom de fichier invalide

Si vous rencontrez ce genre d'erreur en essayant de récupérer les photos de votre appareil photo :

<Nom de l'appareil photo>. Impossible d'obtenir la liste des fichiers: -111: Nom de ficher invalide

FIXME De mémoire, message exact en français oublié… La version anglaise vient de google. Ou en anglais :

<Nom de l'appareil photo>. Failed to get folder list: -111: Invalid filename

C'est que vous avez vraisemblablement un appareil photo dont le constructeur prête peu d'attention aux utilisateurs linux, par exemple un Canon EOS 300D Digital Rebel.

Pas de panique, vous pouvez quand même récupérer vos photos en ligne de commande, selon la méthode préconisée ci-dessus.

Erreur de connexion

Si vous tentez d'accéder par connexion USM à un appareil photo Canon, il se peut que vous obteniez le message suivant :

Error initialising camera: -1: Unspecified error

Le bug sur launchpad se trouve ici et l'un des commentaire donne une solution qui fonctionne (pas toujours semblerait-il). Il faut tuer un processus (/usr/lib/gvfs/gvfs-gphoto2-volume-monitor) avant d'ouvrir le programme allant servir à accéder aux photos (digiKam, nautilus, shotwell…). Donc dans un terminal :

killall /usr/lib/gvfs/gvfs-gphoto2-volume-monitor

Ressources

Pages sur le sujet



Le contenu de ce wiki est sous licence : CC BY-SA v3.0