Contenu | Rechercher | Menus

Ceci est une ancienne révision du document !



Effectuer la migration de Ubuntu Feisty 7.04 vers Ubuntu Gutsy 7.10

La version finale d'Ubuntu 7.10 est sortie le 18 octobre 2007. Cette version sera supportée pendant 18 mois.

Feisty est une version obsolète. Les dépôts correspondants ne sont plus présents dans les dépôts officiels Ubuntu. Pour mettre votre Feisty à jour, il vous faudra utiliser les dépôts archivés old-releases.

De même pour Gutsy. Les nouveaux dépôts pour faire la migration devront également être ceux archivés dans old-releases.

Remarques importantes

  • Vous ne pouvez migrer vers Gutsy (Ubuntu 7.10) qu'à partir de Feisty (Ubuntu 7.04). Si vous disposez d'une version antérieure, vous devrez mettre à niveau d'abord vers Feisty, puis revenir à ce tutoriel.
  • Votre version de Feisty doit être parfaitement à jour avant de réaliser la migration, surtout en vous assurant que le paquet (k)(x)ubuntu-desktop soit bien installé (selon votre version). Sinon, l'intégralité des nouveaux paquets ne pourra être mise à jour.
  • Vous devez avoir 2 Go d'espace libre sur le disque environ pour pouvoir procéder à l'installation. Cet espace servira à stocker les fichiers temporaires nécessaires à l'installation, qui seront supprimés automatiquement en fin d'installation …
  • Les assistants de migration désactivent les dépots tiers (Medibuntu, Beryl, wine…) pour n'effectuer que les mises à jour officielles. Cela veut donc dire que vous devrez passer vous-même ces dépôts manuellement en version Gutsy, s'ils existent, (ou les réactiver) après la mise à jour.
  • Comme pour les mises à jour classiques, vous pouvez continuer à utiliser l'ordinateur pendant son déroulement. Mais comme les changements apportés sont importants, il n'est pas conseillé d'utiliser l'ordinateur de manière trop intense pendant l'étape d'installation des paquets. Cela pourrait rendre instables les applications utilisées.
  • Si vous avez installé des pilotes de carte graphique manuellement, ou par Envy, sans passer par les dépôts, votre serveur X sera cassé au premier redémarrage. Donc prenez vos précautions: soit vous avez la description de la procédure d'installation en mode console sous la main, soit vous savez éditer le xorg.conf en mode console, ou si vous n'êtes pas sûr de vous, repassez en pilote libre/par défaut avant de mettre à jour (pilote nv pour nvidia, ati pour ati, ou vesa pour les autres, à indiquer dans le xorg.conf).

Migration vers la version 7.10 (Recommandé) via les outils Ubuntu

Tout d'abord, remplacez vos dépôts officiels par les dépôts archivés, afin de vous assurer que tout est à jour avant la migration. Consultez cette page pour plus d'informations.

Méthode pour Ubuntu, Xubuntu et Edubuntu

  • Ouvrez le gestionnaire de mises à jour (Système→Administration→Gestionnaire de mises à jour)
  • Cliquez sur Vérifier
  • Installez les mises à jour en cliquant sur Installer les mises à jour si il y en a.
  • Ensuite un bandeau vous indiquant qu'une nouvelle version est sortie doit apparaître
  • Cliquez sur Mettre à jour au bout de cette ligne

Si vous avez un problème

Ouvrez un terminal ou faites alt+F2 et tapez:

gksu 'update-manager -c'

Si ça ne marche toujours pas tournez-vous vers la méthode manuelle.

Méthode pour Kubuntu

  • Ouvrir Adept_Manager en allant dans KMenu→Système→Mise à jour Adept (Gestionnaire de paquetages).
  • Dans le menu Adept → Gérer les dépots onglets Updates, cochez Mises à jour recommandées et Mises à jour en pré-version
  • Puis dans l'onglet Third-party Software, décochez toutes les sources de logiciels présentes.
  • Après confirmation de votre part, les dépôts se rechargent : procédez si besoin à la mise à jour (bouton Tout mettre à jour)
  • Fermez Adept
  • Réouvrez Adept_Manager en allant dans KMenu→Système→Mise à jour Adept (Gestionnaire de paquetages)
  • Cliquez sur Recharger
  • Un bouton Mise à niveau de la version (une très grosse flèche bleue) est apparu, vous n’avez plus qu’à l’enfoncer ;-)
  • Un assistant apparait, suivez-le.

Il se peut que l'assistant plante au tout début, il vous suffira simplement de le fermer, puis de fermer Adept et recommencer (rechargez, et cliquez sur le bouton…)

Des captures d’écran de l’opération (en anglais) figurent ici : http://kubuntu.org/~jriddell/kubuntu-upgrade/

Si ça ne marche pas tournez-vous vers la méthode manuelle.

Après la migration, si vous ne pouvez plus accéder aux dossiers partagés avec Samba, il faut ouvrir /etc/samba/smb.conf en root et supprimer les lignes contenant : msdfs proxy = no

Migration à partir du CD/DVD Alternate

Utilisez cette méthode si l'ordinateur que vous souhaitez upgrader n'est pas connecté à Internet.

  1. Téléchargez et gravez le cd d'installation "alternate" (liens sur cette page)
  2. Insérez le cd dans votre lecteur
  3. Choisissez "Demarrer à partir du premier Disque Dur"
  4. Vous verrez lorsque Ubuntu se lance une boite avec plusieurs Options cliquez sur "Mettre à jour ma distribution"

Si cette boite de dialogue ne s'affiche pas, ouvrez un terminal et tapez : Pour Gnome:

gksu "sh /cdrom/cdromupgrade"

Pour KDE:

kdesu "sh /cdrom/cdromupgrade"

Méthode manuelle ou en ligne de commande (Non recommandée)

Cette méthode peut être utile en cas de problèmes avec update-manager ou si vous n'avez pas accès à l'interface graphique (un serveur)

Préparation

  • Éditez le fichier /etc/apt/sources.list
  • Commentez (c'est à dire ajoutez un # devant) les dépôts que vous avez ajoutés manuellement
  • Remplacer tous les feisty par gutsy dans le fichier texte qui apparait:

Pour le faire plus rapidement vous pouvez utiliser la fonction Remplacer de votre éditeur de texte

Les dépôts Gutsy étant également obsolètes, la liste des dépôts pour Gutsy doit également pointer vers le dépôts old-releases. Consultez cette page pour plus d'informations.

  • Enregistrez le fichier et fermez

Installation

Maintenant installons les mises à jour.

Par le terminal

Pour actualiser la liste des dépôts, utilisez la commande:

sudo apt-get update

Puis pour installer les mises à jour, utilisez la commande:

sudo apt-get dist-upgrade

La même chose peut être faite avec aptitude en remplaçant simplement apt-get par aptitude.

Par le gestionnaire de paquet

  • Ouvrez Synaptic (Ubuntu et Xubuntu) ou Adept (Kubuntu)
  • Cliquez sur Recharger
  • Ensuite cliquez sur Tout mettre à jour
  • Puis Appliquer
  • La mise a jour devrait se faire après confirmation

Problèmes possibles

La mise à jour a échoué en plein milieu

Problème très rare, mais possible… Il se peut que l'installation des mises à jour plante, ou que vous ayez eu une coupure de courant…

Si cela arrive, n'ayez crainte, il n'est pas trop difficile de corriger ce genre de problèmes. Suivez juste ces instructions :

  • Si l'ordinateur est toujours allumé, fermez le gestionnaire de paquet ou de mises à jour (vous devrez peut-être le « killer » avec le moniteur système), essayez d'ouvrir un terminal.
  • Si l'ordinateur est éteint, ou que le terminal ne peut pas s'ouvrir, éteignez l'ordinateur « de force », puis rallumez le.
    • Un démarrage normal ne marchera sans doute pas…
    • Si vous n'avez que Ubuntu sur votre ordinateur, au décompte (une note en haut de l'écran) appuyer sur la touche Echap (Esc).
    • Vous devez tomber sur le menu démarrage, choisissez le noyau « Linux 2.6.20-* (recovery) » (une entrée contenant ce texte, souvent la quatrième de la liste).
    • Vous devez ensuite tomber sur une sorte de terminal en plein écran.
  • Dans tous les cas, pour terminer les installations qui étaient en cours, tapez :
sudo dpkg --configure -a
  • Puis pour installer les mises à jour qui n'ont pas pu être faites, tapez :
sudo apt-get dist-upgrade
  • Redémarrez à présent la machine en tapant :
sudo reboot
  • Une fois la machine relancée, le système doit être à jour.

Note importante

Attention, si vous mettez à jour par la méthode manuelle, les paquets obsolètes ne sont pas supprimés. Certains peuvent poser problème, en particulier evms. Si vous n'arrivez pas à redémarrer l'ordinateur et que vous avez une floppée de messages du type :

device-mapper: table: 254:1: linear: dm-linear: Device lookup failed

il faut démarrer sur l'ancien noyau (kernel) et supprimer le paquet evms :

 sudo apt-get remove evms 

puis redémarrer à nouveau sur le noyau standard.

Dépôts de Gutsy

La liste des dépôts pour Gutsy est disponible sur cette page.

Liens


Contributeurs : Lestat the vampire, woshee, OverSu, Fabien26, FireWave.



Le contenu de ce wiki est sous licence : CC BY-SA v3.0