Contenu | Rechercher | Menus
Selon les tags présents sur cette page, celle-ci est ancienne et ne contient plus d'informations sur une des versions supportées d'Ubuntu.
Selon les tags présents sur cette page, les informations qu'elle contient n'ont pas été vérifiées depuis Ubuntu 10.04 LTS.
Apportez votre aide…

Google SketchUp

SketchUp est un logiciel de CAO propriétaire longtemps publié par Google, depuis racheté par Trimble. Il permet de modéliser des pièces en 3D de façon très conviviale à l'aide d'outils simples (rotation, extrusion, déplacement, etc.). Étant surtout axé sur l'architecture, il peut également être utilisé dans d'autres secteurs, comme l'ébénisterie.

Il se décline en deux versions :

  • SketchUp, une version gratuite avec un ensemble de fonctionnalités de base ;
  • SketchUp Pro, une version payante qui ajoute le support de plusieurs formats d'importation et d'exportation, ainsi que la création de mises en plan et de présentations 2D.

Bien qu'aucune version Linux ne soit disponible, il est possible d'utiliser la version Windows sous Ubuntu par deux méthodes :

  • La virtualisation d'un système d'exploitation Windows (XP/Vista/7), pourvu que l'accélération matérielle soit prise en charge (avec Virtualbox par exemple).
  • À l'aide de Wine, une couche logicielle de compatibilité qui permet l'installation d'application Windows dans Ubuntu.

Pré-requis

  • Une configuration PC suffisante : voir le matériel recommandé pour Windows XP ici ;
  • Une carte graphique supportant l'accélération graphique (ATI, Intel ou Nvidia) ;
  • Avoir installé Wine.

Installation

Virtualisation ou Wine ?

Quelle méthode choisir ? Chacune a ses avantages et inconvénients. Les principaux sont les suivants :

Avantages Inconvénients
Virtualisation compatibilité complète – plus exigeant en ressources système
– licence Windows requise
Wine installation directe dans Ubuntu – intégration imparfaite (décoration de fenêtre, icônes, polices)
– quelques problèmes d'affichage

L'installation et l'utilisation de SketchUp dans Windows, virtualisé ou non, ne concerne pas Ubuntu ni GNU/Linux en général. Cette page traitera donc de l'installation à l'aide de Wine et de ses éventuelles difficultés.

Si vous souhaitez en savoir plus sur la virtualisation, consultez la documentation « Virtualisation de systèmes d'exploitation ».

Depuis la version 7.1 de SketchUp et les versions récentes de Wine, il reste très peu de problèmes de compatibilité avec Ubuntu. SketchUp tourne à merveille sur des PC avec cartes graphiques Intel récentes (ex. : GMA 4500MHD) et Nvidia.

Installation avec Wine

  1. Téléchargez le logiciel d'installation Google SketchUp en français
  2. Lancez le logiciel d'installation ; si cela ne fonctionne pas, faites un clic droit pour obtenir le menu contextuel, et sélectionnez Ouvrir avec Wine Exécuter des programmes Windows ;
  3. Suivez les instructions du logiciel pour compléter l'installation.

Utilisation

Lancez l'application depuis le menu Applications → Wine → Programmes → Google SketchUp 7/8 → Google SketchUp.

Le logiciel d'installation crée un raccourci-lanceur sur le bureau (Google SketchUp 7/8), ainsi qu'un lien Windows inopérant (Google SketchUp 7/8.lnk). Vous pouvez supprimer ces derniers sans problème.

Formats de fichiers

La version gratuite de SketchUp enregistre les documents dans son propre format .skp, qu'aucune application libre ne peut ouvrir. Les formats d'importation et d'exportation 3D sont les suivants :

  • Importation: DEM (.dem, .ddf), 3DS (.3ds), Google Earth (.kmz) et COLLADA (.dae)
  • Exportation: Google Earth (.kmz) et COLLADA (.dae)

Problèmes connus

Décalage dans le rafraîchissement lors du zoom

Dans certaines configuration, il se peut que votre environnement ait un décalage dans le rafraîchissement de la fenêtre. Pour fixer le problème, voici 2 solutions:

Editer le fichier: ~/.PlayOnLinux/shortcuts/Google SketchUp''
Ajouter la ligne: export vblank_mode="0"

  • Si vous lancez directement avec wine

Editer le fichier: ~/.bashrc
Ajouter la ligne: export vblank_mode="0"
Relancez votre session

Maintenant plus de problème d'affichage lors du lancement de Google Sketchup

Fenêtre de travail noire

Dans le menu principal, aller à Wine/Configurer Wine, puis dans l'onglet Affichage :

  • sélectionner Support du Vertex Shader : Aucun
  • décocher Utiliser le Pixel Shader (si supporté par le matériel)

(Testé sur Ubuntu Lucid, Wine 1.2, SketchUp 8, carte graphique intégrée VIA Tech.)

« SketchUp was unable to initialize OpenGL »

Si vous obtenez cette erreur au lancement, lancez cette commande dans un terminal:

wine regedit

Pour SketchUp 8 : Dans l'Éditeur du registre, effectuez ces changements sous les clés :

  • HKEY_USERS/S-1-5-4/Software/Google/SketchUp8/GLConfig/Display
    • modifier [HW_OK] à 1

Il est possible que au tout premier lancement un crash se produise, mais il est semble-t-il sans conséquence et ne se reproduit pas.

Pour SketchUp 7 : Dans l'Éditeur du registre, effectuez ces changements sous les clés :

  • HKEY_CURRENT_USER\Software\Google\SketchUp7\GLConfig\Display\
    • modifier [HW_OK] à 1
    • [FIRST_TIME] = 0 (créer valeur dword ou mot double)
  • HKEY_CURRENT_USER\Software\Google\SketchUp7\Preferences\
    • modifier [EnableCheckValidity] à 0

Plantage après « Bienvenue dans SketchUp »

Si SketchUp plante lorsque vous cliquez sur Commencer à utiliser SketchUp, décochez Afficher au démarrage puis redémarrez l'application.

S'il n'est pas possible de décocher Afficher au démarrage, débranchez votre connexion internet puis essayez à nouveau.

( problème supposé être résolu depuis la version 1.1.11 de Wine; voir bug 16164 )

Pointeur avec fond blanc opaque

Ce problème semble survenir avec les cartes graphiques ATI. Il n'y aurait malheureusement pas de solution pour l'instant.

Ce bug semble fixé depuis la version 1.3.6 - voir ticket de bug 23096

Certains modèles type inaccessibles dans « Bienvenue dans SketchUp »

Un problème d'affichage masque la barre de défilement dans la fenêtre « Bienvenue dans SketchUp »; comme cette fenêtre ne peut être redimensionnée, seuls les deux premiers modèles sont visibles, et le troisième l'est partiellement.

S'il n'existe pas de correctif, on peut accéder à la liste complète des modèles type, et sélectionner celui par défaut, par le menu Fenêtre → Préférences, catégorie Modèle type, puis cliquer sur le bouton Parcourir…

Banque d'images 3D inaccessible dans SketchUp

Le bouton Télécharger des modèles ouvre une fenêtre Internet Explorer pour naviguer la Banque d'images 3D Google; avec une installation dans Wine, cette fenêtre n'arrive pas à afficher le site, ou génère des erreurs de script ; on peut cependant ouvrir séparément un navigateur Web, télécharger les modèles 3D désirés, puis les importer dans le document actif via le menu Fichier → Importer…

La procédure suivante règle souvent le problème :

  • Dans le répertoire wine "c:/Program Files", renommer le répertoire "Internet Explorer" en "ie" (mv "~/.wine/drive_c/Program Files/Internet Explorer" "~/.wine/drive_c/Program Files/ie") ;
  • Télécharger et lancer winetricks (http://wiki.winehq.org/winetricks), sélectionner ie8 et gecko et en lancer l'installation ;
  • Désinstaller, aussitôt après, Internet Explorer 8 ;
  • Effacer le répertoire "Internet Explorer" fraichement recréé dans "c:/Program Files" (rm -Rf "~/.wine/drive_c/Program Files/Internet Explorer") ;
  • Restaurer sous le nom "Internet Explorer" le dossier "ie" mis de côté à la première étape (mv "~/.wine/drive_c/Program Files/ie" "~/.wine/drive_c/Program Files/Internet Explorer").

Ceci doit fonctionner avec les versions 7.1 et 8 de Sketchup.

Impression noire

L'aperçu avant impression donne un cadre totalement noir. L'impression elle-même donne le résultat de l'aperçu.

On peut palier à ce problème comme décrit (en anglais) sur cette page,

http://bugs.winehq.org/show_bug.cgi?id=26250#c1

Il faut ouvrir l'aperçu d'impression et cocher la case "Utiliser le mode de haute précision HLR" comme ci joint :

et

Exportation Graphique 2D vide

Quel que soit le format choisi (png/jpg/bmp), cela donne une page transparente ou noire.

Pour exporter en 2D, utilisez plutôt une capture d'écran.

une fois passé la fenêtre de bienvenue, l’application plante

Faire un clic droit sur l’application et ajouter /DisableRubyAPI à la fin de la ligne « commande »

(Testé sur Ubuntu 14.04 LTS, Wine 1.6.2, SketchUp 2014.)

source (en) : http://appdb.winehq.org/objectManager.php?sClass=version&iId=30063&iTestingId=83789

Désinstallation

On peut supprimer cette application via le menu Applications → Wine → Uninstall Wine Software.

Voir aussi



Le contenu de ce wiki est sous licence : CC BY-SA v3.0