Contenu | Rechercher | Menus

OpenBVE

Openbve semble ne pas se lancer avec 14.04 Trusty Tahr. Selon https://bugs.launchpad.net/ubuntu/+source/openbve/+bug/1273393/comments/16 le problème se trouve dans le paquet libgdiplus.

Un contournement, (testé en architecture i386) consiste à utiliser le paquet libgdiplus de la 13.10, trouvable à ftp://ftp.ubuntu.com/ubuntu/pool/main/libg/libgdiplus/ , la version étant actuellement 2.10-3ubuntu1 (attention à l'architecture : par exemple pour i386 le paquet a aujourd'hui (16/06/2014) pour nom libgdiplus_2.10-3ubuntu1_i386.deb).

Pour empêcher le gestionnaire de paquets de revenir à la version fautive :

sudo -s
echo "nom_du_paquet hold"|dpkg --set-selections

Une fois que le bogue aura été corrigé, pour revenir à une situation de mise à jour normale :

sudo -s
echo "nom_du_paquet install"|dpkg --set-selections

Simplification : La section installation manuelle est a refaire afin d'en extraire sa partie "Utilisation" spécifique, et recréer une section "Utilisation" commune au 2 versions proposées.

Approfondir : Il manque une section installation de contenu supplémentaire (nomenclature des dossiers …)

OpenBVE est un logiciel de simulation de conduite de trains qui s'inspire du gratuiciel BVE, acronyme de Bozo View Express.

OpenBVE fonctionne aussi bien sous Linux, Mac OS X que sous Windows. Il utilise OpenGL pour l'accélération 3D, OpenAL pour le son, ainsi que la SDL. La version Linux fonctionne avec la plate-forme Mono.

wj-r_openbve_64.jpg wj-r_openbve_60.jpg wj-r_openbve_23.jpg

Historique

BVE fut développé par le japonais Takashi Kojima de 2000 à 2008. Face au manque de nouveautés, le projet OpenBVE voit le jour et sort sa première version stable sous licence Open Source en 2009.

Bien que son code soit totalement indépendant de celui de BVE Trainsim, il est développé pour être compatible avec le contenu réalisé pour BVE et ajouter de nouvelles fonctionnalités. Les routes et trains de BVE2 et BVE4 fonctionnent généralement correctement avec OpenBVE, mais il existe de nombreuses routes adaptées ou développées spécialement pour OpenBVE.

Durant l'année 2012, alors que le logiciel est en version 1.4.1.2, un des développeurs principaux quitte le projet. Le site internet officiel disparaît mais le projet est cependant repris par les autres développeurs du projet et une version 1.4.2 est publiée. Le gestionnaire d'extension disparaît de cette dernière version, en attendant la mise en place d'un site officiel permettant d’héberger le contenu.

Fonctionnalités

La modélisation des trains permet d'adopter une vue depuis l'intérieur de la cabine avec l'affichage d'un panneau de commande fonctionnel (voyants, boutons, leviers…), mais aussi extérieur permettant de voir les voitures ou wagons depuis le bord de la voie. Les portes des voitures sur les trains les mieux modélisés peuvent s'ouvrir et se refermer lors des phases d'embarquement des voyageurs. Le bruitage des moteurs et des annonces à bord est également adapté à chaque train.

Côté simulation des routes, la signalisation est gérée incluant signaux et limitation de vitesse, tout comme les équipements de sécurité tel le système japonais ATS permettant la régulation de la vitesse ou le freinage d'urgence en cas de faute du conducteur.

L'ajout de contenu est réalisé par la communauté OpenBVE qui modélise de nouveaux trains et de nouvelles routes ou améliore les modélisations existantes.

Pré-requis

Installation et utilisation

Par les dépôts

Installation :

OpenBVE 1.4.0.9-1 est présent dans les dépôts à partir de Ubuntu 10.04, pour installer ce logiciel, il suffit d'installer le paquet OpenBVE.

Utilisation :

Lancez l'application depuis le menu Applications → Jeux → OpenBVE ou via la commande suivante :

openbve

Manuelle

Installation :

INCOMPLET La version 1.4.2 n'a été testé qu'après installation de la 1.4.0.9-1 présente dans les dépôts (dépendances pré-installées) et donc de manière impropre (en doublon), mais son installation brut n'a pas été testé et devrait être vérifiée par des utilisateurs confirmés.

En attendant, le "guide" d'installation rapide peut être trouvé sur le site officiel (en).

OpenBVE 1.4.2 (dernière version au 22.01.2013), peut être téléchargé sur le site d'un des développeurs principaux, ou sur le mirroir non officiel de la communauté anglophone.

Le gestionnaire d'extension qui ne fonctionnait plus a disparu de cette dernière version, en attendant la mise en place d'un site officiel permettant d’héberger le contenu.

Utilisation :

Après avoir installé les dépendances et extrait l'archive téléchargée, lancer OpenBve.exe ou via la commande suivante :

/CHEMIN_DE_L_ARCHIVE/mono OpenBve.exe

Il vous faudra ensuite télécharger et installer des contenus personnalisés, mais si vous avez installé cette version après la 1.4.0.9-1, vous trouverez déjà :

les routes : /usr/share/games/bve/Railway/Route

les trains : /usr/share/games/bve/Train

Désinstallation

Pour supprimer cette application, il suffit de supprimer son paquet. Selon la méthode choisie, le configuration globale de l'application est conservée ou supprimée. Les journaux du système, et les fichiers de préférence des utilisateurs dans leurs dossiers personnels sont toujours conservés.

Voir aussi



Le contenu de ce wiki est sous licence : CC BY-SA v3.0