Contenu | Rechercher | Menus
Selon les tags présents sur cette page, celle-ci est ancienne et ne contient plus d'informations sur une des versions supportées d'Ubuntu.
Apportez votre aide…

Antidote Rx, correcteur d'orthographe et de grammaire

Antidote est un outil moderne, rapide et pratique pour la rédaction en français. C'est un logiciel intégré d'aide à la rédaction et de correction du français écrit (orthographe, grammaire, etc.). Il regroupe dix grands dictionnaires et dix guides linguistiques. Il interagit intelligemment avec ces dictionnaires et les textes en rédactions pour explorer tous les aspects d'une question linguistique. Antidote est intégrable au traitement de texte Writer de OpenOffice.org 2.

Antidote est un logiciel propriétaire commercial.

Pré-requis

  • Acheter la boîte du logiciel Antidote RX.
  • S'enregistrer (par Internet, par téléphone ou par courrier postal). Voir les instructions sur http://www.druide.com/.

Ubuntu 13.04 et supérieur

L'installation ne devrait pas trop poser de problème si vous pensez a installer

sudo apt-get install gksu

puis une fois gksu installé, il ne vous reste plus qu'à installer le logiciel (pensez à déplacer le sript du cd à votre répertoire personnel et à le rendre exécutable).

gksu bash Installe_Antidote.bash

Enfin, il ne vous reste plus que les mis à jours.

Ubuntu 9.04

Non officiellement compatible, testé avec RX v7 et v8

La v7 ne fonctionne pas mais une fois mise à jour (voir site officiel) cela fonctionne parfaitement!

En 64 bits

Druide travail sur une version 64 bit de antidote, cependant il est déjà possible de faire fonctionner antidote sur une version 64.

Pour cela deux moyen :

  • A l'installation choisir autre distribution (64 bits)
  • Modifier le fichier "/etc/dpkg/dpkg.cfg" et ajouter "force-architecture", ensuite choisir Ubuntu, autre version à l'installation.

Pour le reste reportez vous au explication précédente…

Remarque : les extensions (dans OOo, firefox, …) ne fonctionne pas!

Ubuntu 8.04 et 8.10

Testé avec le CD de la v2, v3, v5 et v7 également.

  1. Installez le paquet kdelibs ou cliquez directement sur son nom. Ce paquet permet d'installer le nécessaire au bon fonctionnement d'Antidote RX, sans lui l'installation échoue.
  2. Insérez le CD d'Antidote RX dans votre ordinateur.

Avec Nautilus, copier l'installeur d'Antidote RX (il est dans « /media/cdrom0/Linux » un simple copier-coller suffit) dans votre répertoire personnel, c'est important pour la suite des choses.

  1. Maintenant nous allons rendre l'installateur d'Antidote RX exécutable (obligatoire) et ensuite lancer l'installation. Le plus simple est d'utiliser la commande suivante (dans un terminal) :
    sudo chmod 755 Installe_Antidote && sudo ./Installe_Antidote
  2. Lisez la licence. Si vous l'acceptez, passez à la suite, sinon vous pouvez fermer cette page.
  3. Une fois la licence acceptée, continuez en choisissant l'installeur dpkg pour Ubuntu.
  4. Finalement, il faut cliquer sur le bouton « Terminer » pour procéder à l'installation sur votre ordinateur.
  5. Une fois terminé, l'installeur vous demandera le numéro de série fourni dans la boîte (carte postale verte et blanche dans la pochette du CD) puis il vous demande votre code d'activation que vous avec obtenu a l'étape 2. Si vous ne l'avez toujours pas il est possible d'utiliser Antidote RX pendant une période de 30 jours.
  6. Voilà c'est installé ! Vous trouverez Antidote RX dans Applications → Bureautique → Antidote RX pour Ubuntu ou dans KDE → Bureautique → Antidote RX pour Kubuntu.
  7. Vous pouvez supprimer le fichier de l'installeur que vous aviez copié à partir du CD au début.

Sur certain ordinateurs fonctionnant sous Ubuntu 7.10, Antidote refuse les codes d'activations. La première fois, en ayant une erreur 60, récupérez un nouveau code d'activation et ressayer. Vous devriez avoir un code d'erreur 15,15. Cette erreur est due à l'oubli du mot de passe root, donc Antidote ne peut sauvegarder le code d'activation. Pour cela, vous n'avez qu'à ouvrir le terminal et exécuter Antidote avec les droits du super-utilisateur (déconseillé) :

sudo antidote

Druide Informatique fournit régulièrement des mises à jour, fermez Antidote RX et on attaque ça tout de suite (en cours d'écriture).

Mise à jour

Vers la version 3 d'Antidote Rx

Pour choisir la mise à jour, vous devez connaître le numéro de version de votre exemplaire d'Antidote. Pour cela, ouvrez Antidote, choisissez "À propos d'Antidote" dans le menu « Aide », prenez-en note le numéro de version qui se trouve dans le coin supérieur droit de la fenêtre qui apparaît. Ne vous contentez pas du nom de l'édition qui apparaît sur la boite d'Antidote. Le numéro qui apparaît dans le logiciel est plus précis.

Téléchargez la mise à jour du site de Druide Informatique dans votre répertoire personnel, c'est important pour la suite des choses : http://druide.com/maj_linux.html

Assurez-vous qu'Antidote n'est pas en cours d'utilisation, qu'il est fermé, sinon vous devrez tout désinstaller et tout réinstaller.

Pour la version 2 à 3, entrez les deux commandes suivantes :

chmod 755 Maj_Antidote_RX_v2_v3_Linux
sudo ./Maj_Antidote_RX_v2_v3_Linux

Pour la version 1 à 3, entrez les deux commandes suivantes :

chmod 755 Maj_Antidote_RX_v1_v3_Linux
sudo ./Maj_Antidote_RX_v1_v3_Linux

De la version 3 à 4 d'Antidote Rx

Pour choisir cette mise à jour, vous devez connaître le numéro de version de votre exemplaire d'Antidote. Pour cela, ouvrez Antidote, choisissez "À propos d'Antidote" dans le menu « Aide », prenez-en note le numéro de version qui se trouve dans le coin supérieur droit de la fenêtre qui apparaît. Cela doit être la version 4.

Téléchargez la mise à jour du site de Druide Informatique dans votre répertoire personnel, c'est important pour que les commandes qui suivent fonctionne : http://www.druide.com/maj_linux.html

Le lien directe est : mise à jour RX v3 à v4 pour Linux (18,1 Mo)

Assurez-vous qu'Antidote n'est pas en cours d'utilisation, qu'il est fermé, sinon vous devrez tout désinstaller et tout réinstaller.

Pour la version 3 à 4, entrez les deux commandes suivantes :

chmod 755 Maj_Antidote_RX_v3_v4_Linux
sudo ./Maj_Antidote_RX_v3_v4_Linux

Une boîte de dialogue souvre et vous demande un mot de passe, entrez votre mot de passe sudo et la mise à jour s'effectuera.

Depuis aujourd'hui (22-04-2007), mon intégration avec Open Office 2.0.4 et Firefox 2.0.0.3 et Thunderbird 1.5.0.10 ça fonction avec la nouvelle mise à jour de la version 3 vers la 4.

Avec la mise à jour de la version 3 à la version 4 d'Antidote, l'intégration à Oppen Office 2.0.4, Firefox 2.0.0.3 et Thunderbird 1.5.0.10 fonctionnent correctement. Je suis sous Kubuntu 6.10.

Il faut installer manuellement Antidote dans Firefox et Thunderbird en suivant les instructions du document d'installation dans Firefox et Thunderbird, et ce document est dans le dossier « /usr/local/Druide/Antidote/Texteurs/Firefox/ ».

Voici les instructions pour faire l’installation d’Antidote dans Firefox 1.5 ou 2.0 et Thunderbird 1.5. Cette méthode consiste à installer une extension XPI dans le logiciel.

Mise à jour de la version 7 d'Antidote Rx

N'oubliez pas de vous déplacer dans le dossier ou vous avez enregistré le fichier téléchargé !

Pour la version 6 à 7, entrez les deux commandes suivantes :

chmod 755 Maj_Antidote_RX_v6_v7_Linux
sudo ./Maj_Antidote_RX_v6_v7_Linux

Si après la mise à jour vous avez le message suivant : "Le nombre de copie par licence d'antidote est atteint."

1) Désinstallez Antidote RX ⇒ Système⇒ Gestionnaire de paquet Synaptic

2) Supprimer le dossier /usr/local/Druide/

3) Réinstallez Antidote RX

4) Télécharger la mise à jour à l'adresse suivante : http://druide.com/maj_linux.html

5) Vérifiez le fonctionnement d'Antidote RX.

Dans les champs de rédaction des pages du site Web d'Ubuntu-fr.org, le texte sélectionné n'est pas reconnu et traité par Antidote 4. Il faut copier-coller le texte en mode autonome dans Antidote.

Activation version 7

Pour activer Antidote Rx après une mise à jour de la version 7 il faut lancer Antidote avec la commande sudo.

sudo antidote

Sinon il vous sera impossible d'activer votre produit: erreur "15,15"

Configuration

Installation dans Firefox 1.5 , 2.0 ou 3.0

  1. Appuyez sur les touches « Alt+F2 » pour ouvrir un dialogue de lancement de commande.
  2. Dans la boîte de dialogue qui s'ouvre, inscrivez la commande suivante :
    • Pour Firefox 1.5 : firefox /usr/local/Druide/Antidote/Texteurs/Firefox/1.5/Antidote_Mozilla_3.xpi
    • Pour Firefox 2.0 : firefox /usr/local/Druide/Antidote/Texteurs/Firefox/2.0/Antidote_Mozilla_3.xpi
    • Pour Firefox 3.0 : firefox /usr/local/Druide/Antidote/Texteurs/Firefox/3.0/Antidote_Mozilla_3.xpi
  3. Firefox se lancera avec un dialogue demandant la confirmation de l'installation de l'extension.
  4. Cliquez sur le bouton « Installer maintenant ».
  5. Quittez Firefox complètement.

Installation dans Thunderbird 1.5

  1. Ouvrez Thunderbird 1.5.
  2. Dans le menu « Outils », choisissez « Extensions ». La fenêtre des extensions de Thunderbird apparait.
  3. Cliquez sur le bouton « Installer ». La fenêtre d’ouverture de fichier apparait.
  4. Furetez jusqu'au dossier d'Antidote, soit le chemin suivant : /usr/local/Druide/Antidote/Texteurs/Thunderbird/1.5/
  5. Ouvrez le fichier « Antidote_Mozilla_3.xpi ».
  6. Thunderbird demandera une confirmation de l’installation. Cliquez sur le bouton « Installer maintenant » dans la fenêtre de confirmation qui apparait.
  7. Quittez Thunderbird complètement.

Intégration dans OpenOffice.org ≥ 2.2

Sous Ubuntu/Kubuntu 8.10

  1. Ouvrez le traitement de texte d'OpenOffice.org Writer.
  2. Dans le menu « Outils », sélectionnez l'option « Gestionnaire d'extensions… »
  3. Dans le gestionnaire, cliquez sur le bouton « Ajouter… »
  4. Dans le gestionnaire de fichiers qui apparaît, naviguez pour sélectionner le fichier « /usr/local/Druide/Antidote/Texteurs/OpenOffice.org/Antidote-OOo.uno.pkg ».
  5. Cliquez sur le bouton « Ouvrir »
  6. Après l’installation, fermez le Gestionnaire de packages en appuyant sur le bouton « Fermer »,
  7. Redémarrez le traitement de texte OpenOffice.org Writer.

Problèmes et solutions

Le lancement d'Antidote RX v3 bloque

Modification de la configuration d'OpenOffice.org 2.x pour utiliser Antidote :

cd /opt/openoffice.org2.x/program/
sudo mv libstdc++.so.6 libstdc++.so.6.tmp
sudo mv libgcc_s.so.1 libgcc_s.so.1.tmp
sudo ln -s /usr/lib/libstdc++.so.6 opt/openoffice.org2.x/program/libstdc++.so.6

N'oubliez pas de modifier la valeur 2.x pour votre version d'OpenOffice. La version de la librairie libgcc n'est pas remplacée (et ça ne cause aucun problème jusqu'à maintenant),

Messages d'erreurs

Si lors de l'utilisation les messages d'erreurs suivants apparaissent :

Les définitions du Petit Druide ne sont pas disponibles. / Code 801
Erreur d'initialisation. Impossible de poursuivre l'exécution de la commande.
Erreur à la lecture du fichier. / Les données de l'index du Visuel n'ont pu être chargées.

Il s'agit d'un problème de permission d'accès aux fichiers locaux qui peut être résolu de la manière suivante :

sudo chmod -R 777 /usr/local/Druide/Antidote

Paquet libstlport4.6c2 manquant

Lors de l'installation d'Antidote, il est possible qu'il vous indique que le paquet libstlport4.6c2 est manquant. Dans ce cas, il faut "Ignorer et tenter l'installation". Antidote ne fonctionnera pas, mais il suffit de le mettre à jour, vers la version 8 pour que tout rentre dans l'ordre. http://www.druide.com/maj_ancien_linux.html

Voir aussi

Autres pages en lien avec les sujets



Le contenu de ce wiki est sous licence : CC BY-SA v3.0