Contenu | Rechercher | Menus

gLabels


gLabels (sous licence GNU) est un utilitaire dédié à la création de séries de documents en petits formats tels que : étiquettes, pochettes et cartes de visite.

Atouts :

  • Gestion des séries à l'impression
  • Légèreté
  • Nombreux modèles pré-configurés (templates)
  • Assistant didactique pour la création de modèles
  • Gestion des codes barres
  • Possibilité de publi-étiquetage issus de bases de données

Limites :

  • Approximation dans la conversion des mesures (à vérifier)
  • Limite des fonctionnalités de l'outil texte (mais il est maintenant possible d'ombrer le texte)
  • Défilement dans les listes par saisie de l'initiale impossible

Installation

Il suffit d'installer les paquets glabels et glabels-data (dépôt Universe).

gLabels est maintenant disponible dans le menu Applications → Bureautique.

Configuration

Normalement les paramètres devraient être définis correctement à l'installation du programme. Sinon : Pour régler les préférences, allez dans :
Menu Édition → Préférences onglet Paramètres régionaux.
Comme Unités, choisissez Millimètres et pour la Taille de page par défaut, sélectionnez ISO A4.
L'onglet Paramètres par défaut pour les objets permet de définir d'autres préférences.

Utilisation

Nous allons prendre pour exemple des cartes de visites. Mais la procédure est la même pour des étiquettes, des pochettes, etc.

1 - Création d'un modèle personnalisé de cartes de visite


gLabels propose énormément de modèles pré-définis qui devraient vous convenir. Dans ce cas vous pouvez passer directement à la création des cartes de visites proprement dites. Si malgré tout, vous voulez créer votre propre modèle, suivez les instructions de ce chapitre.

L'assistant Créateur de Modèles


Allez dans Menu → Fichier → Créateur de modèles

1ère étape

Cliquez sur Continuer pour passer la page de bienvenue.

2ème étape

À l'écran Nom et description, saisissez les informations demandées. Par exemple, pour Marque/Fabriquant vous pouvez mettre "0-Moi", en N° Ref "cv", et dans la Description, "Mes cartes de visites 2015".

Si vous faites commencer la marque par un chiffre, ce modèle sera en première place dans la liste de choix.

Lorsque ces trois informations sont saisies, vous pouvez cliquer sur Continuer.

3ème étape

Cliquez sur Continuer à l'écran Taille de page puisque le format de la page a déjà été défini dans la configuration par défaut.

4ème étape

Sur l'écran Forme de carte ou d'étiquette, il faut choisir la forme, soit dans notre exemple : Rectangulaire.

Les choix possibles sont :
- Rectangulaire ou carré avec possibilité de bords arrondis.
- Circulaire
- Elliptique (de forme ovale)
- CD/DVD (c'est-à-dire rond avec un cercle vide au milieu).


Cliquez sur Continuer.

5ème étape

À l'écran Taille de carte ou d'étiquette, saisissez les mesures.

Dans le cas de modèles du commerce, une feuille de mesures est souvent fournie avec le papier.

Vous pouvez vous aider du dessin explicatif à droite de l'écran.

Les Déchets correspondent à ce qui sera imprimé au delà des limites du modèle de l'étiquette.
- La valeur 0 est conseillée lorsqu'il y a un risque de perte d'information. Par exemple que le nom soit tronqué sur les cartes de visites, parce que partiellement imprimé au delà des lignes de coupe.
- Dans le cas d'étiquettes rondes pour CD, autoriser une petite surcharge (1 à 3 mm) peut s'avérer une bonne idée si ce n'est qu'une petite partie de l'image qui risque d'être coupée.

Cliquez sur Continuer.

6ème étape

Passez l'écran suivant qui vous propose de choisir le Nombre de dispositions en cliquant sur Continuer et en laissant la valeur par défaut = 1.

Une seule disposition est le cas le plus fréquent. Comme expliqué dans gLabels, il correspond à une symétrie définie au centre de la feuille.

7ème étape

Choisissez la Disposition.

L'espacement vertical = la hauteur d'une étiquette + la distance souhaitée entre deux étiquettes.
L'espacement horizontal = la largeur d'une étiquette + la distance souhaitée entre deux étiquettes.

Pour des étiquettes sur papier du commerce pré-découpé, choisir les espacements minimums (égaux à la largeur et à la hauteur d'une étiquette.)


Cliquez sur Imprimer une page de test pour évaluer le résultat.

Par exemple en mettant votre page de test sur la page de test généralement fournie avec le papier du commerce, puis en regardant par transparence devant une source lumineuse.

Si c'est satisfaisant cliquez sur Continuer.

Sinon vous pouvez cliquer sur Revenir et modifier les valeurs qui posent problème.

8ème étape

Sur l'écran Création terminée, cliquez sur Appliquer pour valider votre nouveau modèle.

Intermède (pour être plus précis)


Ayant mentionné dans les limites de Glabels mon sentiment que ce programme ne convertit que de façon approximative les mesures je dois m'en expliquer et proposer une solution.
Il est crucial que les mesures soient très exactes, sinon les erreurs vont se cumuler, et les étiquettes de fin de page seront positionnées différemment qu'en début de page.
C'est pour cela que je conseille d'autoriser la surcharge quand c'est possible.
Mais dans le cas d'étiquettes pré-découpées, en cas d'approximation, les dernières étiquettes pourront être imprimées sur la ligne de coupe et la surcharge n'est donc pas possible.
Une solution est de modifier le fichier /home/nom_d'utisateur/.glabels (fichier caché) dans lequel sont stockés les modèles créés par l'utilisateur.
On remarque que les valeurs ont été automatiquement converties en point alors qu'elles ont été saisies en millimètre.
Il faut donc convertir les millimètres en points (il existe des convertisseur sur le net) et modifier les mesures qui posent problème.
De cette manière, il est possible de faire des réglages très fins, puisque jusqu'à 4 décimales sont autorisées.


Un exemple de fichier :

Les valeurs qu'on peut modifier sont :
width Largeur de l'étiquette
height Hauteur l'étiquette
round Arrondi de l'étiquette
x_waste Déchet horizontal
y_waste Déchet vertical
Autant de lignes Layout que de colonnes d'étiquettes (avec nx=1) ou une seule ligne layout et nx=nombre de colonnes d'étiquettes par page (dans le cas de plusieurs dispositions différentes par page)
ny Nombre d'étiquettes par colonne
X0 Distance par rapport au bord gauche (marge à gauche)
Y0 Distance par rapport au bord haut (marge en haut)
dx Espacement horizontal (= largeur étiquette + distance entre 2 étiquettes)
dy Espacement vertical (= hauteur étiquette + distance entre 2 étiquettes)

Les modifications seront prises en compte (le fichier étant enregistré) lorsque ce modèle sera ouvert par la commande Nouveau dans gLabels.

2 - Création des cartes de visites


Fichier → Nouveau
Choisir son modèle. Trois possibilités de recherche :
L'onglet Utilisation récente qui recense donc les derniers modèles que vous avez utilisé.
L'onglet Recherche globale qui permet un tri par Marque, Taille de page et par Catégorie.
L'onglet Personnalisè qui recense les modèles que vous avez créé.
Valider en cliquant sur Continuer
Choix de l'orientation, Normal qui correspond à la position verticale ("portrait") ou Pivoté pour la position horizontale ("paysage").
Continuer
L'écran Révision permet de valider la vue d'ensemble en cliquant sur Appliquer

Les Outils :
La flèche pour sélectionner un objet, le déplacer et le déformer
Le T pour insérer une zone de texte
Le carré jaune pour insérer une forme carrée ou rectangulaire
Le cercle jaune pour insérer une forme ronde ou ovale
La barre oblique pour insérer une ligne droite
Le code barre pour insérer un code barre
L'image colorée pour insérer une image
Quatre loupes pour autant de modes de zoom
La feuille avec des fiches (tout à droite) pour insérer les champs d'une base de données

Chaque objet sélectionné ouvre une interface de modification adaptée à droite dans la fenêtre.

Les petits triangles noirs à gauche et à droite de cette nouvelle fenêtre permettent de naviguer entre les onglets des nombreuses options disponibles.

Le menu Objets propose quand à lui des options communes à tous les types d'objet.


Exemple : Pour insérer une image, cliquez l'icône image colorée, cliquez sur l'étiquette, cliquez-glissez puis lâchez. Dans la fenêtre de droite qui s'ouvre choisissez l'onglet Image, cliquez sur l'icône dossier (à droite de Fichier : (Aucun)), sélectionnez l'image sur votre ordinateur puis validez.

On sélectionne plusieurs objets en leur cliquant dessus tout en maintenant la touche Ctrl enfoncée ou en "cliquant-glissant" avec la souris.

3 - Impression

Pour configurer l'impression, il suffit d'aller dans le menu Fichier → Imprimer puis dans l'onglet Étiquettes.


Il est possible d'imprimer une ou plusieurs pages complètes d'étiquettes.
Il est également possible de n'imprimer qu'une seule étiquette ou une série d'étiquettes, en choisissant la position, soit en saisissant son numéro, soit en "cliquant-glissant" avec la souris. Ceci est intéressant quand on souhaite imprimer, par exemple, qu'un exemplaire d'une étiquette pour CD.

Il est également possible d'imprimer les guides de coupe, les bordures (pour tester le modèle) et/ou à l'envers.


L'Impression paysage quand à elle, peut être utile dans le cas de grandes étiquettes.
En effet, si la largeur de l'étiquette dépasse la largeur de la page (21 cm pour le format A4), il reste possible d'imprimer en "paysage" (29,7 cm pour le A4).
Pour cela, il faut concevoir le modèle comme si la page devait être imprimée en "portrait", puis d'imposer une rotation à l'étiquette lors de l'ouverture du modèle : Fichier → Nouveau → Choix de l'orientation → Pivoté.

Vous pouvez choisir de créer un fichier PDF ou PostScript en sélectionnant Imprimer dans un fichier dans l'onglet Général.

Les possibilités avancées de gLabels


Je ne peux pas terminer ce petit tour d'horizon sans mentionner deux points qui font que gLabels peut intéresser même les professionnels.

1. La prise en charge des codes barres

gLabels permet d'insérer des codes barres dans les étiquettes, et cela avec un large choix de formats supportés, dont les codes : EAN, UPC, CODE39 et ISBN.

2. La possibilité d'intégrer aux étiquettes les informations d'une base de données.

Le format classique CSV est supporté. Mais aussi Vcard. Et bien sûr il est possible d'importer les informations du carnet d'adresses d'Évolution.

Désinstallation

Pour supprimer cette application, il suffit de supprimer son paquet.

Voir aussi



Le contenu de ce wiki est sous licence : CC BY-SA v3.0