Contenu | Rechercher | Menus
Selon les tags présents sur cette page, les informations qu'elle contient n'ont pas été vérifiées depuis Ubuntu 12.04 LTS.
Apportez votre aide…

 Logo d'Openshot

OpenShot Video Editor

Écrit en PyGTK, OpenShot Video Editor est un logiciel nouvelle génération de montage vidéo non-linéaire. Il est multi-pistes audio / vidéo / image et permet l'utilisation de transitions et d'effets (audio et vidéo) dans une interface claire et agréable. Il s'adresse à la fois aux débutants et aux personnes exigeantes. Il offre le support du format Haute Définition AVCHD.

Malgré toute les qualités d'OpenShot, il peut être nécessaire de convertir le format AVCHD qui se révèle très exigeant avec les petites configurations (CPU monocoeur par exemple et carte graphique datée). Le compagnon d'OpenShot pour ce travail de préparation se nomme HandBrake qui se révèle aussi instinctif.

Voir les fonctionnalités offertes par OpenShot en vidéo sur le site officiel.

Capture d'écran d'Openshot

Pré-requis

Installation

Depuis les dépôts officiels

OpenShot Video Editor est disponible dans les dépôts officiels. Il suffit d'installer le paquet openshot.

Dernière version stable

Vous pouvez installer une version plus récente que celle des dépôts depuis le PPA officiel du projet.

Ajoutez le PPA ppa:openshot.developers/ppa1) à vos sources de logiciels, ensuite retrouvez le PPA dans la liste et remplacez edg par edge pour les deux entrées, puis rechargez la liste des paquets, et enfin installer le paquet openshot.

Attention, ceci désinstalle le paquet libsdl1.2debian-alsa pour le remplacer par libsdl1.2debian-pulseaudio (à prendre en compte si vous avez désinstallé PulseAudio).

Février 2012 : Une nouvelle version d'OpenShot est disponible sur le PPA sus-mentionné : OpenShot 1.4.2. Cette version ne fonctionne pas directement sur Oneiric (11.10). Se référer à cette discussion pour résoudre ce problème.

La dernière version d'OpenShot est la 1.4.3. sortie le 01 octobre 2012.

Version de développement

Un nouveau PPA a été mis en service depuis le 13 septembre 20112). Il s'agit d'un Daily PPA qui permet au testeur de suivre chaque commit fait dans le trunk. À partir de ce PPA, l'utilisateur bénéficie des dernières avancées du projet mais la version obtenue n'est pas utilisable en production. L'objectif est de bénéficier d'un maximun de remontées de bugs avant la finalisation d'une milestone. A n'utiliser qu'à vos risques et périls.

Ajoutez le PPA ppa:openshot.developers/daily3) à vos sources de logiciels, puis rechargez la liste des paquets, et enfin installer le paquet openshot.

Ce genre de PPA est réservé aux gens expérimentés et aux testeurs. Comme tout Daily PPA, il est fortement instable et n'est donc pas recommandé pour une utilisation de tous les jours. Cependant, les remontées de bugs sont fortement appréciées.

Pour des raisons de nomenclature, le numéro de la version est identique à la dernière en date cependant vous pouvez vérifier la version non seulement dans les crédits mais aussi lors de son lancement en console

Par compilation des sources

Les indications ci-dessous vont vous permettre d'installer la version de développement d'OpenShot. Elle peut comporter davantage de bogues, mais elle permet de participer au débogage d'OpenShot et de disposer des toutes dernières fonctionnalités. Elle peut cohabiter avec une version d'OpenShot installée via les dépôts.

  1. Installer bzr (ou bazaar-explorer pour disposer d'une interface graphique pour bazar) ;
  2. Créer le dossier où vous souhaitez installer la version de développement d'OpenShot ;
  3. Se rendre avec le terminal dans ce dossier ;
  4. Lancer la commande suivante pour télécharger la version de développement (cela peut prendre un temps assez long) :
    bzr branch lp:openshot
  5. Une fois l'action de la commande terminée, se rendre dans le dossier openshot contenant openshot.py et lancer la commande
    python openshot.py

Pour mettre à jour la version de développement, se rendre avec le terminal dans le dossier openshot créé précédemment, puis lancer cette commande :

bzr pull

Source

Utilisation

Lancez l'application depuis le menu Applications → Son et vidéo → OpenShot Video Editor ou via la commande suivante :

openshot

L'utilisation d'Openshot est détaillée dans son Manuel d'utilisation, que vous pouvez installer en installant le paquet openshot-doc.

Une version en ligne est disponible ici

Problèmes connus

Pour rapporter un bug, pensez à utiliser la FAQ correspondante qui dispose d'un modèle de rapport de bug.

Pensez à jeter un œil aux FAQ existantes. Elles vous guideront vers une solution rapide à votre problème.

Bugs d'affichage lié au framework MLT

OpenShot est tributaire de son framework vidéo MLT. Or celui-ci, comme tout programme informatique, n'est pas exempt de bogues. Nous en avons recensé trois selon les versions qui provoquent différents problèmes d'affichages.

  • Le 1er concerne la version 0.4.4 (version par défaut d'Ubuntu Karmic Koala 9.10) qui se traduit par l'apparition de grosses lignes verticales vertes, blanches ou roses. Certaines personnes l'ont résolu par la désactivation de Compiz (solution provisoire en attendant une nouvelle version de MLT corrigeant ce bogue).
  • Le 2ème concerne la version 0.5.0 qui se traduit par l'apparition de fines lignes verticales blanches ou vertes vers les bords de l'image. Il a été corrigé par la version 0.5.2 qui a elle-même introduit un autre bogue corrigé avec la version 0.5.4. (Voir cette discussion.)
  • Le 3ème concerne la version 0.5.4 (version par défaut d'Ubuntu Lucid Lynx 10.04) qui se traduit par l'apparition de pixels blancs style effet de neige. Il semblerait que la version 0.5.5 corrige ce bogue.

Pour installer MLT 0.5.5 sur Ubuntu 10.04, il suffit d'ajouter à vos sources de logiciels le PPA suivant : ppa:agateau/ppa , recharger la liste des paquets, puis installer (ou mettre à jour) le paquet mlt.

Ces problèmes d'affichages sont totalement résolus depuis la version 0.5.10 de MLT

Problème avec la documentation sur Ubuntu 10.04

Une incompatibilité entre la 1ère et la 2ème version de la documentation apparaît sur Lucid au moment de la mise à jour de OpenShot, ce dernier ne sachant plus quel fichier lire. Il faut alors désinstaller la 1ère version, openshot-doc2.0.1-4, puis installer la 2ème, openshot-doc1.1.0~alpha2-Oubuntu1.

Dépendances manquantes

OpenShot Video Editor a besoin de dépendances pour fonctionner correctement. Pensez bien à vérifier si de nouvelles dépendances n'ont pas été ajoutées ou bien enlevées, ici sur ce wiki, sur la page dédiée de LProd ou sur la page française spécifique dans le forum de la communauté des utilisateurs d'OpenShot.

La suppression, la modification ou l'ajout de dépendances est lié à l'évolution du projet, ce qui fait que cette liste n'est pas figée.

Vérification des dépendances pour la version 1.3.0 et suivantes (à partir de Ubuntu 9.04 jusqu'à 11.04)

Pour faire fonctionner cette version d'OpenShot (PPA pour l'instant jusqu'à son intégration dans les dépôts officiels de Ubuntu 11.04) sur toutes les versions (à partir d'Ubuntu 9.10), il faut avoir installé les paquets x264 ffmpeg python python-xdg python-gtk2 python-imaging python-pygoocanvas libgoocanvas3 libgoocanvas-common python-mlt2 melt libmlt libmlt-data libmlt++3 frei0r-plugins sox librsvg2-common libsdl1.2debian-pulseaudio fontconfig.

Pour la version 1.4.0, il faut ajouter à cette liste (et seulement pour Oneiric) gtk2-engines-pixbuf

Vérification des dépendances pour Ubuntu 10.04 et supérieur

Titres

Titres 3D

Open Shot est capable de réaliser des titres 3D, grâce au célèbre Blender. A partir de la version 1.2.2-1 et en attendant la sortie de la version stable de Blender afin de bénéficier du Créateur de Titres 3D Animés, vous devez installer la version de développement (qui est parfois capricieuse) que vous trouverez ici.

Vous avez deux méthodes pour obtenir cette version de Blender, compatible avec la version officielle pour la deuxième méthode :

Soit vous installez le PPA suivant : ppa:cheleb/blender-svn Puis vous rechargez la liste de paquets et installez Blender ;

Soit vous téléchargez la version de Blender correspondant à votre système, puis décompressez l'archive dans le dossier de votre choix. Renommez-le si vous le désirez puis lancez OpenShot et ouvrez les préférences, 1er onglet. Modifiez le chemin pour pointer vers l'exécutable de Blender puis relancez OpenShot afin d'avoir accès au Créateur de Titres 3D animés.

Titres classiques

Open Shot propose des titres beaucoup plus classiques, que vous pouvez quand même modifier de fond en comble en installant InkScape. La version Inkskape des dépôts officiels convient avec la version PPA d'OpenShot.

Désinstallation

Pour supprimer cette application, il suffit de supprimer ses paquets. La configuration de l'application sera conservée ou supprimée selon la méthode de désinstallation que vous choisirez.

Si vous voulez supprimer les fichiers de configuration, ils se trouvent dans le répertoire ~/.openshot

Voir aussi



Le contenu de ce wiki est sous licence : CC BY-SA v3.0