Icône de LibreOffice

LibreOffice

LibreOffice est une suite bureautique libre, gratuite, multi-plateforme et complète (traitement de texte, tableur, application de présentation, etc.), ce qui fait d'elle une excellente alternative aux suites bureautiques propriétaires telles que Microsoft Office, Microsoft Office Online, Google Docs, …

C'est une suite applicative très modulaire : des extensions, des modèles, des images, des thèmes, des polices sont librement mis à disposition par la communauté.

Sur la plupart des variantes d'Ubuntu, LibreOffice est installé en tant que suite bureautique par défaut.

  • Bien vérifier la version de LibreOffice qui s'est installée, surtout si vous souhaitez la version stable ! Ouvrez LibreOffice puis Aide → À propos de LibreOffice pour voir votre version installée.
  • Regarder sur le site de LibreOffice le numéro de la dernière version stable.

LibreOffice est un fork de la suite libre de bureautique OpenOffice.org, développée par The Document Foundation, une fondation regroupant la communauté de développeurs d'OpenOffice.org ainsi que différents partenaires comme la FSF, OASIS, Google, Novell, Red Hat, Canonical, OSI, …

LibreOffice prend notamment en charge les formats Open XML de Microsoft Office (.docx, .xlsx, .pptx), mais peut avoir des difficultés à les lire.

Il est préférable de lire/modifier ces types de fichiers avec les applications de Microsoft et de les enregistrer dans des formats ouverts comme OpenDocument (.odt, etc.) ou faute de mieux dans les anciens formats de Office (antérieurs à 2007 : .doc, .xls, .ppt) qui sont mieux pris en charge par LibreOffice.

Installation

Il existe plusieurs méthodes au choix pour installer LibreOffice :

  • Il est disponible dans les dépôts officiels APT d'Ubuntu.
  • Il est distribué par ses développeurs en Flatpak.
  • Il existe un paquet snap non-officiel.
  • LibreOffice est aussi disponible en AppImage sur son site officiel.
  • LibreOffice est aussi disponible depuis un PPA, mais cette méthode est désormais déconseillée.
Vous trouverez aussi des informations en anglais concernant le téléchargement et l'installation de LibreOffice sur son site officiel.

Il existe aussi un fork de LibreOffice proposant des fonctionnalités avancées de travail collaboratif nommé Collabora.

Dépôts officiels APT

Pour avoir accès à ce paquet, il faut que le dépôt Universe soit activé dans les sources de logiciels.

LibreOffice est installé par défaut sous la plupart des variantes d'Ubuntu.
Pour installer LibreOffice quand il n'est pas installé, ou pour réinstaller LibreOffice, installez les paquets suivants :

Recherchez simplement LibreOffice dans votre gestionnaire de paquets et installez ce qui vous convient.

Les paquets de langues de votre système seront aussi installées. Dans le cas contraire, pour le français, installez les paquets libreoffice-l10n-fr libreoffice-help-fr hyphen-fr.

Les extensions incluses dans LibreOffice

La version provenant du site officiel de LibreOffice donne une liste de 6 extensions que l'on peut installer à la demande. Celles-ci sont activées par défaut, mais elles ne sont pas disponibles sur le site des extensions LibreOffice.

Pour les retrouver dans le Centre d'applications, rechercher libreoffice extension ; sinon, voici le nom de chacune et le nom de son paquet :

Il peut arriver que le paquet libreoffice-nlpsolver installé a posteriori ne soit pas actif. Dans ce cas il semble nécessaire de désinstaller puis de réinstaller LibreOffice avec la commande suivante dans un terminal:
sudo apt purge libreoffice* && sudo apt install libreoffice libreoffice-nlpsolver libreoffice-help-fr libreoffice-l10n-fr

Autres exemples d'extensions installables

Les styles d'icônes incluses dans LibreOffice

Pour des questions de place, seul un ensemble restreint de jeux d'icônes est inclus dans la version fournie par Canonical par rapport à la version fournie par The Document Fondation.

Elles peuvent être retrouvées en tapant les mots libreoffice-style dans le Centre d'applications, sinon voici la liste complète :

Un tutoriel en image qui explique comment changer de thème est proposé sur le blog Changer les icônes de LibreOffice — site : Le Blog Libre ; date : 2 novembre 2016.

Flatpak

LibreOffice est aussi distribué par ses développeurs en Flatpak sur le dépôt Flathub.

On peut donc l'obtenir en installant Flatpak avec le dépôt Flathub si ce n'est pas déjà fait, puis en installant LibreOffice depuis GNOME Logiciels, ou en installant le paquet org.libreoffice.LibreOffice en ligne de commande :

flatpak install org.libreoffice.LibreOffice

Snap

LibreOffice est aussi disponible en snap depuis Snapcraft. Cette version est compilée par Canonical.

On peut simplement installer l'application libreoffice depuis le Centre d'applications (Snap Store), ou installer le paquet libreoffice en ligne de commande :

snap install libreoffice

LibreOffice sera constamment à jour et en français. Les extensions que l'on peut ajouter, comme Grammalecte par exemple, fonctionnent correctement.

Cette version en snap ne voit par contre que le support de stockage qui contient votre répertoire personnel. Cette version ne lit pas non plus /usr/lib/jvm/, cela rend une connexion avec une base de données MySQL par mysql-connector-java-5.1 difficile voire impossible, et soulève probablement encore d'autres problèmes.

AppImage

Cette méthode ne permet pas de mise à jour automatique.

L'intégration au système (dont la création d'un lanceur) doit aussi être faite manuellement.

Pour installer une AppImage référez-vous avant tout au chapitre dédié au sujet.

En résumé téléchargez le fichier LibreOffice-XX.X.X.X.full-x86_64.AppImage sur le site officiel ou son dépôt (où XX.X.X.X est le numéro de la dernière version), puis rendez-le exécutable (clic droit sur le fichier → Propriétés → Permissions → Autoriser l’exécution). Finalement lancez-le en double-cliquant dessus.

Vous pouvez utiliser un service tel que appimaged pour créer automatiquement un lanceur.

PPA

L'ajout d'un PPA est plus dangereux que l'utilisation de Flatpak ou snap (voir cet avertissement).

Cette méthode peut aussi poser des problèmes lors d'une mise à niveau.

Vous pouvez aussi installer LibreOffice depuis le PPA libreoffice :

  1. ajouter le PPA de votre choix aux sources de logiciels :
    • Version Still (dite stable) si vous déployez LibreOffice en entreprise ou que vous êtes un utilisateur conservateur : ppa:libreoffice/libreoffice-still1)''
    • Version Fresh si vous êtes un passionné de technologie, un adepte précoce ou un utilisateur expérimenté : ppa:libreoffice/ppa2)
    • Version Alpha, beta (conçues seulement pour les testeurs…) : ppa:libreoffice/libreoffice-prereleases3)
  2. Puis pour chaque langue installée sur votre système et/ou à l'aide de laquelle vous désirez accéder, installez le paquet d'internationalisation libreoffice-l10n-XX (ou XX est le code de la langue).
    Par exemple pour le français (fr) : libreoffice-l10n-fr.

Collabora

À l'instar d'Office Online 365 de Microsoft, LibreOffice possède également sa version collaborative en application web ; il s'agit de Collabora Online Development Edition ou CODE (fork de LibreOffice Online qui semble abandonné4)).
Cette version de Collabora Online est libre et peut être auto-hébergée et éventuellement intégrée en app à Nextcloud.

Collabora est aussi disponible en application de bureau sous la forme de Collabora Office. Celui-ci est disponible en Flatpak sur le dépôt Flathub et peut donc s'obtenir en installant Flatpak, puis en installant le paquet com.collaboraoffice.Office.

Seuls certain services cloud liés à Collabora sont propriétaires et parfois payants.

Configuration

Accélérer LibreOffice

Dans le but d'optimiser la suite LibreOffice, vous pouvez vous référer à la page :

Installer des extensions pour LibreOffice

* Téléchargez l'extension (Enregistrer sous).

  • Allez dans Outils → Gestionnaire des extensions puis cliquez sur le bouton Ajouter
  • Sélectionnez l'extension, puis cliquez sur le bouton Ouvrir.

Pour les extensions se trouvant dans les dépôts, il suffit d'installer les paquets en question.

Rotation d'images

L'extension Writer Rotation Tool permet de tourner facilement les images dans Writer.

Extensions pour l'éducation

Installer des correcteurs grammaticaux

Voir la page dédiée à la correction grammaticale (Grammalecte).

Éditeur d'équation sous LaTeX

Éditeur d'équations mathématiques en LaTeX : TexMaths

Export en images pour Impress et Draw

Impress et Draw permettent de base d'exporter une page sous forme d'image. Si vous devez convertir une présentation de 30 pages pour l'inclure dans une vidéo, cela va être fastidieux. Il suffit d'ajouter l'extension export-as-images.

Vignettes d'aperçu (thumbnails)

Les méthodes ci-dessous permettent d'afficher dans le navigateur de fichiers les miniatures des fichiers OpenDocument.

Méthode Nautilus Thunar Dolphin Nemo Caja PCManFM
Paquet ooo-thumbnailer Fonctionne Fonctionne : voir ici Incompatible : voir ici Fonctionne Fonctionne Fonctionne
Script Nicolas Bernaerts Fonctionne Incompatible Incompatible Fonctionne Fonctionne Fonctionne
Les dernières versions modifiées — de ooo-thumbnailer et MSOffice-thumbnailer — par Nicolas Bernaerts suite à un échange de mails avec eagle08 fonctionnent avec tous les gestionnaires de fichiers — à l'exception de Dolphin 4.xx qui ne prend en compte aucun des fichiers cités — testés au 14 mars 2018 sous Xenial V.3.
La version présentée plus bas au paragraphe Méthode 1 a été modifiée et testée par eagle08 ; elle permet d'introduire des variables ; dès lors, vous pouvez ajouter autant de variables MimeType que vous le souhaitez en ajoutant une ligne de déclaration, par exemple :
OOOtext=application/vnd.oasis.opendocument.text;
GenericTextFormat=text/x-gettext-translation;text/plain;
IDETextFormat=text/x-c;application/x-compactpro;application/x-csh;text/x-script.csh;application/x-pointplus;text/css;text/x-fortran;text/vnd.fmi.flexstor;text/x-h;
…
MimeType=$graphics&&$presentation&&$spreadsheet&&$OOOtext;&&$GenericTextFile&&$IDETextFormat

La liste complète des variables MimeTypes— (en) The Complete List of MIME Types ; site : Site Point ; Auteur : Ophélie Lechat ; date : 15 août 2015.

Méthode 1 : grâce à ooo-thumbnailer

Installez le paquet ooo-thumbnailer.

Vérifier au préalable que le paquet libgsf-bin soit bien installé.

Cependant, il arrive qu'un bogue empêche son bon fonctionnement, voici comment le régler :

  • Avec permissions administrateur, créer le fichier /usr/share/thumbnailers/ooo.thumbnailer et copiez-y le contenu suivant :
    /usr/share/thumbnailers/ooo.thumbnailer
    usr/share/thumbnailers/ooo.thumbnailer>
    #!/bin/bash
     
    usr/share/thumbnailers/ooo.thumbnailer>
     
    # déclaration des variables mime type de documents
     
    graphics=application/vnd.oasis.opendocument.graphics;
    presentation=application/vnd.oasis.opendocument.presentation;
    spreadsheet=application/vnd.oasis.opendocument.spreadsheet;
    text=application/vnd.oasis.opendocument.text;
     
    [Thumbnailer Entry]
     
    TryExec=ooo-thumbnailer
    Exec=/usr/bin/ooo-thumbnailer %i %o %s
    MimeType=$graphics&&$presentation&&$spreadsheet&&$text
  • Sauvegarder le fichier et redémarrer Nautilus :
    rm -r $HOME/.cache/thumbnails
    nautilus -q

Méthode 2 : grâce à un script de Nicolas Bernaerts

Il est possible de faire afficher des vignettes d'aperçu dans le navigateur de fichiers pour les fichiers libreoffice classiques (.odt, .ods, .odg,…) ou flat XML (.fodt,…), grâce à un script de Nicolas Bernaerts présenté en détails sur la page : Nautilus - Thumbnailer for LibreOffice documents

Là où ooo-thumbnailer se contente de produire des versions miniatures des documents en guise d'icônes (comme pour les images ou les fichiers PDF), le script ajoute des captures d'écran avec des petites logos distinctifs en surimpression des miniatures de manière à reconnaître facilement le type de fichier (ce qui pourra être un avantage ou inconvénient selon les goûts).

Installation depuis un terminal :

wget https://raw.githubusercontent.com/NicolasBernaerts/ubuntu-scripts/master/thumbnailer/libreoffice/lo-thumbnailer-install.sh
. ./lo-thumbnailer-install.sh

La première ligne télécharge un script d'installation qu'elle enregistre à la racine de votre répertoire personnel (vous pourrez le supprimer ensuite). La deuxième ligne lance ce script d'installation.

Vous devriez obtenir le résultat suivant :

Pour obtenir des vignettes des documents Ms Office, un thumbnailer est disponible sur la page (Nautilus - Thumbnailer for Ms Office documents)

Installation depuis un terminal :

wget https://raw.githubusercontent.com/NicolasBernaerts/ubuntu-scripts/master/thumbnailer/msoffice/msoffice-thumbnailer-install.sh
. ./msoffice-thumbnailer-install.sh

Créer un document depuis le navigateur de fichiers

Le nouveau document est créé à partir d'un modèle déjà enregistré dans le répertoire ~/Modèles.

Plus de détails dans ce tutoriel.

Changer le(s) modèle(s) par défaut

  1. Créer un document [texte, classeur, présentation, dessin] conforme à ce qu’on souhaite avoir par défaut. En particulier définir la police du ou des styles qui s’appellent Par défaut.
    (LibreOffice 5 et 6)
  2. menu Fichier → Modèles → Enregistrer comme modèle : choisir la catégorie de modèle Mes Modèles avec le nom qu'on souhaite.

et cocher la case Définir comme modèle par défaut.
Le modèle sera stocké dans le répertoire défini pour les nouveaux modèles dans les options de LibreOffice (menu Outils → Options → Chemins → Modèles).
(LibreOffice 4)

  1. menu Fichier → Enregistrer comme modèle : l'enregistrer dans le répertoire Mes Modèles avec le nom qu'on souhaite.
  2. Procéder comme suit pour définir ce nouveau modèle comme étant le modèle par défaut :
    menu Fichier → Nouveau → Modèle → Classeurs

Si le nouveau modèle créé n'apparaît pas dans le dossier (rectangle aux coins arrondis) Mes modèles il faut appuyer sur le bouton Importer et le sélectionner depuis son emplacement Ensuite il faut double cliquer sur le dossier Mes modèles pour ouvrir la liste des modèles

  • On sélectionne le modèle qu’on a créé, on clique sur Définir par défaut
Il y a un bug (mauvaise intégration avec le thème ?) qui fait que le nom du dossier ou du document n'est pas toujours visible. Il faut cliquer sous le rectangle, à l'emplacement du titre pour le voir.

Ajouter des raccourcis d'accès

À chaque mise à jour de LibreOffice, l'opération est à recommencer.

Pour pouvoir ajouter des Quicklists à LibreOffice sur le lanceur, il faut préalablement placer l'application LibreOffice sur le lanceur.

Il faut ensuite modifiez le fichier /usr/share/applications/libreoffice-startcenter.desktop avec les permissions administrateur et y copier le contenu suivant à la fin :

X-Ayatana-Desktop-Shortcuts=Writer;Calc;Impress;Base;Draw;Math
 
[Writer Shortcut Group]
Name=Nouveau document texte
Exec=libreoffice -writer %U
TargetEnvironment=Unity
 
[Math Shortcut Group]
Name=Formule mathématique
Exec=libreoffice -math %U
TargetEnvironment=Unity
 
[Impress Shortcut Group]
Name=Nouvelle présentation
Exec=libreoffice -impress %U
TargetEnvironment=Unity
 
[Draw Shortcut Group]
Name=Nouveau dessin
Exec=libreoffice -draw %U
TargetEnvironment=Unity
 
[Calc Shortcut Group]
Name=Nouvelle feuille de calcul
Exec=libreoffice -calc %U
TargetEnvironment=Unity
 
[Base Shortcut Group]
Name=Nouvelle base de données
Exec=libreoffice -base %U
TargetEnvironment=Unity

Il est bien sûr possible de supprimer certaines parties de ce script pour les raccourcis que vous n'utiliserez pas.

Après avoir copié ce texte, enregistrez le fichier et redémarrez votre session. Un clic droit sur l'icône de LibreOffice du lanceur affiche maintenant les accès rapides.

Installer des polices

Plus d'information sur la page expliquant comment installer de nouvelles polices de caractère.

Pour la version Snap de LibreOffice, vous devez installer vos polices dans ~/snap/libreoffice/current/.local/share/fonts.

Il faut créer le répertoire fonts s'il n'existe pas.

Modifier le nom des polices

Quand LibreOffice découvre de nouvelles polices :

  • soit dans le répertoire polices du système (/usr/share/fonts/),
  • soit dans le répertoire polices de l'utilisateur (~/.fonts),
  • soit dans le répertoire /usr/lib/libreoffice/share/fonts/ des configurations système de LibreOffice,
  • soit dans le répertoire fonts du répertoire des configurations de LibreOffice de l'utilisateur,

il les ajoute à son cache des polices, nommé pspfontcache, qui se trouve dans le répertoire psprint situé dans ce même répertoire des configurations de LibreOffice de l'utilisateur.

En cas de problème ou d'erreur, enlever les polices erronées du répertoire où elles se trouvent, redémarrer LibreOffice, puis les y remettre. Autrement supprimer le fichier pspfontcache.

Dans ce fichier, il indique le nom du répertoire exploré, à chaque changement de répertoire ou de sous-répertoire :

FontCacheDirectory:1335506239:/usr/share/fonts/truetype/msttcorefonts

Il liste ensuite les fichiers de polices qu'il y trouve, en prenant 4 lignes pour chacun, et séparant deux fichiers de polices par une ligne vide. Par exemple, pour le fichier /usr/share/fonts/truetype/msttcorefonts/Comic_Sans_MS.ttf, après l'indication du répertoire exploré, il indique :

File:Comic_Sans_MS.ttf
2;1
Comic Sans MS
-1;ComicSansMS;0;5;5;2;65535;1102;291;393;0;1278;1393;1278;1393;0;0;0;0;Regular

La troisième de ces lignes indique le nom que LibreOffice indiquera pour la police dans le menu déroulant : il est donc possible de le modifier avec soin, par exemple pour donner le même nom à toutes les variantes de taille d'une même police…

Répertoire par défaut

L'emplacement du répertoire de configuration par défaut est : ~/.config/libreoffice/3/user/ ou ~/.config/libreoffice/4/user/.

L'emplacement des scripts python3 de l'utilisateur est : ~/.config/libreoffice/4/user/Scripts/python/.

L'emplacement des scripts python3 pour tous les utilisateurs est : /usr/lib/libreoffice/share/Scripts/python/.

Utilisation

Lancez l'application souhaitée comme indiqué ici. La suite bureautique LibreOffice étant composée de différents modules, adaptez vos recherches en fonction du nom du module voulu.

Vous pouvez également utiliser les commandes suivantes dans le terminal (toutes versions ou variantes) :

  • LibreOffice Writer : traitement de texte
    lowriter    Démarre avec un document Writer vide. 
  • LibreOffice Calc : tableur
    localc    Démarre avec un document Calc vide.
  • LibreOffice Draw application de dessin
    lodraw    Démarre avec un document Draw vide.
  • LibreOffice Impress : application de présentation
    loimpress    Démarre avec un document Impress vide.
  • LibreOffice Math : création de formules mathématiques
    lomath    Démarre avec un document Math vide.
  • LibreOffice Base : Base de données
    lobase    Démarre avec une base de données vide. 

Les fichiers de configurations sont dans le répertoire ~/.config/libreoffice.

LibreOffice Base

Il s'agit d'un module permettant d'utiliser une base de données avec ses différents composants : les tables où sont enregistrées les données, les formulaires permettant de les afficher à l'écran, les rapports pour des impressions et les requêtes (SQL) permettant de sélectionner des données particulières, ou d'en ajouter, d'en supprimer…

En fait, le fichier Base peut embarquer sa propre base de données ou simplement être une « frontale », c’est à dire, l'interface que l'on va développer pour exploiter la base de données. Le format de la base de données n’est pas imposé : Base peut se connecter à différentes bases de données « externes » (un ou des fichiers différents du fichier Base) qui fonctionnent en serveur comme MySQL par exemple. A la création du fichier Base, LibreOffice vous demande quelle est la base de données et le moyen de s’y connecter (voir Connexion à une base de donnée MySQL sous LibreOffice par exemple). Il propose aussi d’utiliser une base de données intégrée.

LibreOffice Base propose d’utiliser une base de données intégrée HSQLDB (à noter : cette option ne fonctionnait plus d'emblée avec les versions 20.04 et 20.10 car les dépendances nécessaires n'étaient pas installées ; cette régression a été corrigée par une mise à jour en avril 2021).

LibreOffice propose aussi une base intégrée au format Firebird à titre expérimental. L'utilisation dans Base aurait de nombreux bogues. Dans cette configuration simplifiée, la base de données fait partie du fichier Base, avec des risques et limites. Une alternative simple à cette base intégrée : utiliser la 3e option Connecter une base de données existante en gardant l'option Firebird. LibreOffice va alors vous demander un nom pour créer le fichier de données Firebird x.fdb puis un nom pour le fichier LibreOffice Base lui-même. La connexion à cette base de données Firebird se fait sans autre complication.

Rapports

Les rapports ou états sont des documents destinés à être imprimés. Ils permettent une mise en forme des données issues de la base que l'on sélectionne par une requête.

Dans les premières versions, l'élaboration de ces rapports supposait une extension Report-builder qui est désormais intégrée. Néanmoins, elle n'est pas installée automatiquement avec Base. Pour l'ajouter, installer le paquet libreoffice-report-builder.

Programmation dans LibreOffice

LibreOfficeffice propose une fenêtre de programmation notamment avec son langage intégré Basic.

Vous pouvez aussi utiliser une interface de programmation (IDE) comme Geany ou Glade.

Apache Open Office Basic & LibreOffice Basic

Les Basic libres résultant des projets de suites office libres : Apache Open Office Basic et LibreOffice Basic différent légèrement. Consultez les ouvrages et sites adaptés.

Pour LibreOffice Base 6.4, l'ouvrage de référence en anglais a été traduit ici.

Les Macros dans LibreOffice

Les macros sont des modules programmés et rattachés à des éléments de la suite (documents, classeurs,…) ou à des évènements en vue de les automatiser. Vous pouvez récupérer des macros sur les sites suivants :

Trouver de l'information d'aide à la programmation :

Le cas particulier de l'extension Basic IDE Tools : Environnement de développement intégré OOBasic

À l'image de l'environnement de développement Visual Basic, il existe une interface équivalente sous LibreOffice.

Pour utiliser l'environnement de développement intégré OOBasic il suffit d'ouvrir d'aller au menu Outils → Macro → Éditer les macros….

Trucs et Astuces

Rendez-vous sur la page consacrée à ce sujet.

Problèmes rencontrés

Désinstallation

Pour désinstaller cette application, il suffit de supprimer son paquet :

Voir aussi

Alternatives